5

I like to use my photo library for a screen saver (have 10,000 photos - it's nice to get to see them more often), but ever since I've downloaded Yosemite, every time the computer goes to sleep, it defaults back to the National Geographic photos (there are maybe 30 of them). Really, really frustrating, and I can't find where to change the default settings to try and make an adjustment. Anyone know how to change that default setting or have any other idea what to do?

  • 1
    Do you use Mission Control and have multiple desktops with Desktop Backgrounds? – bmike Feb 28 '15 at 14:40
1

After trying the other "fixes" and nothing worked, I went with what was previously suggested here. Located the Nat Geo folder (HD>Library>Screen Saver>Default Collections>1-National Geographic) and removed those pictures. This does require your Administrator Password. Then I moved the pictures I wanted into that folder. This works, but it is not a fix as the Screen Saver still defaults to that folder.

1

@Charley3's answer did not work for me, as I constantly update the photos I want in my screen saver. I took it one step further by setting up the mac to copy the photos from my folder to the default national geographic folder once a day on weekdays:

  1. Open Terminal application
  2. Type sudo crontab -e
  3. Type your password
  4. Type i and then paste the following: (03 7 is 7:03am, change to desired update time. 1-5 is Monday-Friday, change to desired days)

    03 7 * * 1-5 cp -a <path to screensaver photos desired>/* /Library/Screen\ Savers/Default\ Collections/1-National\ Geographic/

  5. Type [esc] :wq and hit [Enter]

  6. Type sudo crontab -l and verify the information pasted in is correct

Now I can have the photo folder that I change the contents of daily still be set as my default screensaver folder.

Edit: In addition, I selected the 'shuffle slide order' checkbox in screen saver settings but that too shifts back to the defaults. In order to check this box regularly, I used this question and added an additional line to the crontab:

03 7 * * 1-5 /usr/bin/defaults -currentHost write com.apple.ScreenSaverPhotoChooser 'ShufflesPhotos' -bool "true"

0

It's very frustrating that apple has done nothing about this bug. If you search the forums, a lot of folks have this issue.

If you look at the apple forums there are a couple of workarounds but no fixes.

Two things work for most folks:

  • Find the national geographic folder, delete the pictures there and move your screen saver pictures to that folder

or

  • Leave the screen saver preferences always running (never close the window)

Some of the other solutions offered have mixed results:

  • Deleting the national geo picture folder (works for some, others get a "no pictures message")
  • Deleting system "plist" files (works for some, others claim the problem - returns after a while).
  • Disconnect your system from the internet (Not sure why but some folks claim when not connected to the internet the screen saver does not revert back).
  • deleting the entire national geographic folder worked for me. removing all the mac.screensaver files did not. – user50220 Feb 24 '15 at 23:16
  • Do you have a radar number I can duplicate? Can you reproduce this issue on a new installation? What precise files need to be deleted if you wish to delete "system plist" files? (I am suspicious that the preferences are actually stored in a database as opposed to plist files, but let's see if we can at least nail down where the screen saver settings are stored) – bmike Feb 28 '15 at 14:43
  • @bmike I can see the current selected folder in the file ~/Library/Preferences/ByHost/com.apple.ScreenSaverPhotoChooser.438F481F-1D78-5338-B855-BBEAE4274C8B.plist. It regularly reverts back to the NationalGeographic folder. I tried making the file read-only and will see if it works. – Calimo Mar 28 '15 at 17:21
  • It turns out the plist is erased even when read-only. Also making a copy of the "good" one and copying it back doesn't seem to have any effect. – Calimo Mar 31 '15 at 14:57
  • I tried replacing the NationalGeographic folder with an identically-named symlink to the Dropbox folder I want to use, but when it reverts I still just get a "No Photos" message. I'll try Sashah's method above. – jbkly Apr 2 '15 at 16:15
0

This is not a fix, but a work-around. Goto preferences and in screensaver select your personal photo folder you want to use, in the upper lefthand corner select the yellow (minimizer button) the screen will zoom down to the dock thereby locking your selection open on the dock. Not a fix, but at least you can see your own photos.

This is the only thing I've found that works—picked up from a post somewhere else.

0

I had this same problem. For me it was caused by a configuration profile that was overriding my screensaver preferences. (I had installed the profile while going through Apples OS X Support Essentials book)

Here are Apples instructions :

Remove a configuration profile from your Mac

  1. Choose Apple menu > System Preferences, then click Profiles. If you haven’t installed any configuration profiles, the Profiles pane of System Preferences isn’t available.
  2. Select a profile in the Profiles list, then click Delete (-).

You must log in to answer this question.

protected by Community May 26 '15 at 6:00

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .