1

I have a Mac Mini server running the latest version of Mavericks and server app version 3.2.1. When I first signed up for AT&T U-verse I had a 2Wire 3801HGV modem. I was able to set up web hosting using the server app and Phusion Passenger for my Ruby on Rails applications running Lion Server. Even upgrades to Mountain Lion and Mavericks did not mess up anything. Everything worked as before.

A few months ago all my U-verse services quit working well. The wiring was updated to CAT-50. My modem was changed to the Motorola (Arris) NVG589. Now web browsing is slow at best and my web hosting no longer works. Either my websites do not display at all or they display with no images. I assume the DNS is set up properly for the web hosting because the correct websites show up. I did a clean install of Mavericks and put the same DNS settings as I had when everything was working. I also did a Server Hardware Test just in case something was wrong with my hardware, especially the memory. No problems with the hardware were found. I came to the conclusion the problem is with the NVG589 modem.

I did some web searching on the AT&T site and others and found that the problems I describe occur with the NVG510 and the NVG589 because of a known software bug where the DNS check times out really quick before most websites can display. The only option I have (I guess) is to make my Time Capsule the main router. I found a solution in several places, including the AT&T forum.

I have two questions regarding this:

  1. It was suggested that if the Device IPv4 Address is the same subnet as my personal router's LAN segment that I should change the subnet on my personal router (aka Time Capsule) to something like 192.168.10.0. How can I change this number in Airport Utility (or some other tool)? I could not find a way to do this.
  2. The steps also say to disable the section on the NVG589 where I opened ports 80 & 443. I know that theses ports are already open on my Mac Mini server. How do I open them on the Time Capsule? Right now I am in bridge mode at the advice of an Apple specialist while trying to solve another problem long ago. When I change the router mode of the Time Capsule to DHCP will I be able to open ports using Airport Utility (or some other tool)?

If I cannot resolve this I have lost my development server where I need to be able to test my websites assigned to a domain before deploying to my production server. I checked the AT&T website and the only modem mentioned for AT&T U-verse is another modem that looks similar to the one I have. Maybe it will work but I just wonder.

Any help would be appreciated.

1

I'm going to take it that you're reading something along the lines of these instructions from dslreports.com. If so, to answer your questions:

1) What you're looking for is if the public (WAN) side of the network is using their own DHCP-allocated address pool for the network branch your area is provisioned with. This would be IP addresses that start with 10.x, 192.x or 172.x. These are the same IP ranges typically used for LAN addresses issued by DHCP servers on internal networks. The instruction is to use one of those address ranges that does not match that of the WAN side of the AT&T modem. So let's say that your modem has a 192.x.x.x WAN address: set your Time Capsule to use the 10.x.x.x address range in its DHCP settings. This will prevent matching and conflicting IP addresses as packets are transferred through the modem, as the modem is performing a basic NAT function in relaying the packets.

2) Yes, you need to disable any of the port forwarding done on the NVG589 since all the packets will now need to be handled by the Time Capsule. @colomb's answer shows the configuration section of the Airport Utility where you would need to set up the new port forwarding rules, as well as what mode to operate the Time Capsule in. The "Network Options" button at the bottom of his screenshot is where you will set the DHCP address range for the Time Capsule as well as enabling the NAT Port Mapping Protocol.

The end result of all of this is that the NVG589 will now effectively be just a modem for the AT&T service and your Time Capsule will be your router and DHCP server with your port forwarding configuration.

  • Those are the instructions I'm looking at. I wanted to make sure how to change the address. Point 3 was unclear. Your explanation makes sense. Glad to know they will work. I will check out @columb's answer. The instructions make sense but could not figure out how to update the Time Capsule. Thanks! – Pamela Cook - LightBe Corp Jan 30 '15 at 14:26
  • These instructions work well. However I'm having a challenge with the changes to make in the Time Capsule. I will post my comments on @columb's answer. Thanks again! – Pamela Cook - LightBe Corp Jan 30 '15 at 18:03
0
  1. Do you know if it's possible to put the U-Verse box into bridge mode? That's the customary approach for using Time Capsule as router. If you can do that, you'd attach the U-Verse box to the WAN port on the TC, and set the Internet tab on the TC to DHCP. If no bridge mode, it's tricky, since you don't want to be doing Double-NAT.

  2. If you can get 1. above sorted, you can set up inbound port forwarding in Airport Utility, in the Port Settings of the Network tab. This may be invisible to you if your TC is in Bridge mode at the moment, but it can definitely be done.

enter image description here

Good luck!

  • Technically the instructions above posted by @douggro are to get up IP passthrough set up on the NVG589 modem. There is no nice selection to set it to Bridge Mode like on the Time Capsule. I will change it to DHCP and NAT and see if that works. If not I will try DHCP. I will post my results. – Pamela Cook - LightBe Corp Jan 30 '15 at 14:30
  • I was able to successfully set up the IP Passthrough. However I'm having problems with setting up the Time Capsule. It shows the public IP for the router properly but sometimes that IP changes into an IP address starting with 169.254.. I read that this is a link local ip that is set when DHCP is not working properly. I got a notice in server app stating that the ip of my host was changed. I have no idea where to go from here except figure out what DHCP is not working properly then come back to this. So many REALLY OLD solutions found but nothing that I understand on how to fix this. – Pamela Cook - LightBe Corp Jan 30 '15 at 18:47
  • @LightBeCorp Were you able to get the MAC hardware address for the Time Capsule properly entered in the settings in the NVG589? It sounds like the Time Capsule is losing its DHCP address from the NVG589 and dropping to a self-assigned IP (the 169.254.x.x). – douggro Jan 30 '15 at 19:48
  • @LightBeCorp If you need to determine the MAC address of the Time Capsule, you can use Network Utility to run Netstat on your network and the MAC address will show up in the routing table. – douggro Jan 30 '15 at 19:50
  • @douggro, I was able to get the MAC address of the Time Capsule from the router page. It appears that the instructions worked since when I went into the Time Capsule it knew the public IP address. I'm not sure where the DHCP was getting lost. I did get an alert in the server app about this. It's the first time in 4 years I've seen this. I decided to delete and recreate the Ethernet entry on my Mac Mini server to see if I have problems with losing the DHCP. If I don't lose the DCHP I will try this again and post my results. I will also run Netstat as well. Thanks so much for your help! – Pamela Cook - LightBe Corp Jan 30 '15 at 20:36

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .