2

This question already has an answer here:

I updated to Yosemite a while back, but yesterday iMessage started sending the error message "Not Delivered". I can send messages to non-Apple devices (SMS?) just fine, but not to Apple clients (Apple server?). No problem at all with iPad Air or iPhone 5S, both iOS 8.1.3. Any suggestions would be greatly appreciated!

-Macbook Pro Retina (late 2013) -iPhone 5S -iPad Air

marked as duplicate by kenorb, Ɱark Ƭ, grg Dec 13 '17 at 17:39

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

2

You probably somehow got disconnected from iCloud. First, you should probably log in at icloud.com with the Apple ID that you normally use for the Messages app to ensure you're not having a general account issue. If that's successful, while using the Messages app, select Preferences from the Messages menu. Click Accounts and select the iCloud user that appears for you. Be sure Enabled has a check mark next to it. If it does, remove the check mark and use the provided fields in the window to log back in. If you don't see Enabled, use the provided fields to log into your iCloud account. Once successfully logged in be sure to put a check mark in all the boxes that apply.

1

Go to System Preferences and iCloud, then click on Account Details to verify your connectivity to iCloud.

Otherwise run the following log command in Terminal to debug the problem:

log stream --predicate 'processImagePath contains "Messages"'

or:

log stream | grep -C5 -w Messages

then re-send the message and check for any hints or errors.

See: iMessage stopped working.. Contacts are shown as red now

Not the answer you're looking for? Browse other questions tagged .