9

Yosemite has a new feature where my Mac rings when I get a phone call. Annoyingly, it continues to ring for 30 seconds or so, even after I've answered the iPhone.

How can I turn this sound off? I'd like to continue to have this feature available on my Mac: I'd like to be able to start calls from my Mac and I'd like to see the little alert that says "Accept / Decline" when the calls come in, but I want to turn off the ring sound on the Mac so I can answer my iPhone without having the other person hear endless ringing in the background.

7

Easy Peasy.

System Preferences > Notifications > FaceTime > uncheck 'Play sound for notifications'

Alternatively, you could just turn on 'Do Not Disturb' from the Today/Notifications widget easily when you need it by clicking on the notifications button in the menu bar and scrolling up the 'Do Not Disturb' setting will scroll into view

  • Brilliant! I should've thought of that. Works perfectly. – Bill Jan 29 '15 at 20:34
  • 1
    @Bill - cheers mate. For future references, anything that displays in the form of a notification can be altered in the Notifications System Preferences 99% of the time with ease. – soulshined Jan 29 '15 at 20:41
  • I had this option turned off and I was still getting calls coming in – 1.21 gigawatts Oct 3 '15 at 7:15
  • I done this solution. It still mutes music in the background. No sound though, but it muted my Spotify, while playing music. @1.21gigawatts - if you want to disable the incoming calls, not just notification, you need to disable it from the FaceTime app. See answer below by Patrick McMahon. – FooBar Mar 12 '18 at 15:18
1

Launch /Applications/FaceTime.app

Click on FaceTime > Preferences

Uncheck "iPhone Cellular Calls"

  • 2
    This is not addressing the question. I consider it a bug that the Mac or a connected iPad will continue to ring even after the iPhone has been answered. I'm not aware of a way to selectively turn off the ring tone while still allowing the device to display the incoming call. – KenB Jan 29 '15 at 19:11
  • In the FaceTime preferences, there are several options for which ringtone you want when you receive a new call. Unfortunately, there is not an option for a silent ringtone. I imagine you could easily create a "silent" mp3 or aiff file and add it to the directory where those other ringtones are stored. Those ringtones may very well be stored inside a core audio package file somewhere, though. I checked the usual locations and I couldn't find it. – Patrick McMahon Jan 29 '15 at 19:25
  • @soulshined's answer works! – Bill Jan 29 '15 at 20:34
  • I can't get to my Mac right now to check, but does FaceTime give you the same ringtone options as the iPhone? That would be cool, as I already have a silent ringtone I made for irritating callers. – Tetsujin Jan 30 '15 at 13:04
  • I had this option turned off and was still getting calls. Possibly caused by another application? – 1.21 gigawatts Oct 3 '15 at 7:15
0

Your Mac / PC will also ring if you have hangouts open in GMail. You can go into Settings and turn off "Ring on incoming phone calls".

enter image description here

You can get there by selecting the hangouts icon
enter image description here

and then clicking the disclosure icon next to your username (it's the triangle next to your username).

This will open up settings where you can turn off the notification.

-1

Here is another solution to the problem: http://osxdaily.com/2014/10/17/stop-iphone-calls-ringing-mac-os-x/

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .