I have a mid-2007 iMac that can't boot into OS X Lion unless it's in safe mode. When I turn it on, the Apple logo appears, then the loading spinner, then a white screen with no cursor.

What makes me think it's a graphics issue is that when I boot into Lion recovery, the white screen doesn't get replaced completely by the "steel" background - rather, dragging the Installer window around kind of "erases" the white and lets the steel through, like how the eraser works in Photoshop. I'm thinking this could be related to the graphics card driver, as in safe mode it loads fine and I'm assuming it uses a generic driver there. I've tried the OS it came with (Tiger), and that installs fine but won't boot, only this time getting stuck at a blue screen instead. Oddly enough, Apple hardware test says everything is okay.

I've replaced the hard drive, reset the PRAM and SMC, and done a memory test, and I was wondering if there was anything else I could do or if my hypothesis is correct, finding an alternate way to use the graphics card.

  • is there a Apple Hardware test for your model?
    – Ruskes
    Jan 29, 2015 at 0:23
  • Sorry, I meant to say Apple Hardware test in my post. As mentioned before, it doesn't detect any issues.
    – svbnet
    Jan 29, 2015 at 0:24
  • since it works in safe mode it is usually some 3d party app loading and preventing it to work normally. What do you have installed that would o that ?
    – Ruskes
    Jan 29, 2015 at 0:55
  • I don't have anything installed at the moment, as I tried to reinstall OS X Lion but it can't boot
    – svbnet
    Jan 29, 2015 at 1:02
  • sorry, are you saying now the Lion wont start in Safe mode anymore. Try starting in Single user mode to see where it hangs.
    – Ruskes
    Jan 29, 2015 at 1:40

3 Answers 3


To determine if it is your hardware or OS X boot from external drive. If it works it is your OS X, if not, it is your hardware.

If it is OS X use Safe mode and:

  • look for non apple drivers loaded using sudo kexstsat in Terminal (enter password)
  • None of these except verbose mode are really applicable as it's a fresh install, and even then verbose mode doesn't really help because as soon as it disappears it hangs.
    – svbnet
    Jan 29, 2015 at 3:21
  • OK, fixed my answer.
    – Ruskes
    Jan 29, 2015 at 3:39

in safe mode, go to folder /System/Library/Extensions, then move the files starting with ATI to another folder for example Extensions_tmp. Reboot, now system should be ok, but with reduced graphic capability. try to find the previous versions of the ATI files in your backup, and move them to the Extensions folder.


Unfortunately it does appear to be a graphics issue, as when I removed the ATI kexts in safe mode and restarted, it booted fine, though with abysmal graphics performance as it was using the generic drivers.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .