1

I have a MacBook Pro 13″ and after I had upgraded to Yosemite the device does't go in sleep mode when I want it (anything is disconnected from the device). I went to energy power savings to change my settings but still doesn't work.

This is what terminal shows to me with pmset -g assertions command:

2015-01-29 12:02:35 +0100 Assertion status system-wide: BackgroundTask 0 ApplePushServiceTask 0 UserIsActive 1 PreventUserIdleDisplaySleep 0 PreventSystemSleep 0 ExternalMedia 0 PreventUserIdleSystemSleep 0 NetworkClientActive 0

Listed by owning process: pid 76(hidd): [0x0000de4e000908e3] 00:17:53 UserIsActive named: "com.apple.iohideventsystem.queue.tickle" Timeout will fire in 286 secs Action=TimeoutActionRelease No kernel assertions.

  • Open your Terminal app in the utility folder and type "pmset -g assertions" and report results here, that will tell what is keeping it awake. – Ruskes Jan 28 '15 at 18:41
  • 2015-01-29 12:02:35 +0100 Assertion status system-wide: BackgroundTask 0 ApplePushServiceTask 0 UserIsActive 1 PreventUserIdleDisplaySleep 0 PreventSystemSleep 0 ExternalMedia 0 PreventUserIdleSystemSleep 0 NetworkClientActive 0 Listed by owning process: pid 76(hidd): [0x0000de4e000908e3] 00:17:53 UserIsActive named: "com.apple.iohideventsystem.queue.tickle" Timeout will fire in 286 secs Action=TimeoutActionRelease No kernel assertions. – Mac Jan 29 '15 at 11:04
  • this is what terminal shows to me with pmset -g assertions command – Mac Jan 29 '15 at 11:05
  • Thanks, now we know you have no settings that will keep it awake. So the next one would be try sleep while running in Safe mode to exclude 3d party stuff. – Ruskes Jan 29 '15 at 16:55
1

don't know why but everything went ok and fixed after just two days...thanks a lot anyway! Mac

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .