4

Of course, by holding down on an icon and tap the x lets me uninstall an app. But take a look at this:

enter image description here

Here, the Pandora app is somehow stuck at the "update phase". Tapping it to continue download doesn't work. The progress "circle" will get stuck. So I decided to reinstall it.

enter image description here

Translation:
Delete “”
Deleting “” will also delete all its data.

For some reason it doesn't even show the name of the app. It's just blank.

Tapping delete does nothing. So what do I have to do to fix this problem?

Running iOS 8, not jail broken.

4
  • Have You tried removing this from iTunes? – Mateusz Szlosek Jan 28 '15 at 10:00
  • @MateuszSzlosek I was going to try that, but is this normal..? See this. The gray part is the remaining memory, and from the original 1GB left, it says there will be 19GB remaining afterward. – Derek 朕會功夫 Jan 28 '15 at 10:13
  • How much memory do you have on the iPhone? Could it be that it's trying to install the app, but can't because of memory requirements? Just a stab in the dark here, but thought I'd put my 2c in :D – Often Right Apr 8 '15 at 6:36
  • 1
    @N.Soong I had more than enough memory for it to do it stuff I'm sure. But you are right on one thing that this indeed happened when I was updating the app. Anyway, I tried a lot of way to remove it including removing in iTunes but no luck. And then the 8.2 update came and once I updated it's gone. Guess for some reason the update fixed it. – Derek 朕會功夫 Apr 8 '15 at 17:20
0

Derek. Not a lot of people realize that an iPhone is a computer and should be treated as such. Just like your computer you shut it down or at least restart it on a regular basis. People don't do this with iPhones, because well, it's a phone and they may 'miss a call' or it's just habit for most. It causes a lot of memory leaks especially if developers aren't skilled enough to know how to test within their apps for memory leaks. In other words, a soft restart (turning it off in the normal manner by holding the sleep button and sliding to power off and then turning it back on) will 99% of the time autonomously repair itself and reset the memory. The 1% chance it does not you can do a hard restart (holding the sleep and home button simultaneously for 4-5 sec) will fix your issue.

3
  • I tried both way of turning off but the problem persists. – Derek 朕會功夫 Jan 28 '15 at 16:54
  • @Derek朕會功夫 you should consider a restore or just delete contents and settings? If you are using two different App Store (US and Europes) for example this could be the issue – soulshined Jan 28 '15 at 21:16
  • I only have used the US App Store, but I'll try clearing the settings and data and see if it fixes the problem. – Derek 朕會功夫 Jan 28 '15 at 23:04

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .