2

(My iPhone syncs fine with a bunch of other computers.)

iTunes won't run after installation.

I Download 64 bit iTunes from https://www.apple.com/itunes/download/

The installation on Windows 7 Enterprise goes without a glitch.

When I run it it says "Apple Application Support was not found. Apple Application Support is required to run iTuners. Please uninstall iTunes, then install iTunes again. Error 2 (Windows error 2)" (I get this message twice, with one minor variation. The advice does not help.)

I found articles on the net (https://discussions.apple.com/thread/2151777?start=0&tstart=0) which says to use WinRAR to unpack the installer and then install the components one by one.

Download and install WinRAR.
Right-click the iTunesSetup.exe icon and choose "Open with WinRAR".
Once the EXE is opened in WinRAR, double-click AppleApplicationSupport.msi and when the installer window is open choose "Repair".

iTunes now starts fine.

I connect my iPhone 4S. Nothing happens. It is not charging. iTunes does not discover it.

There is a message about "USB Hub Power exceeded." This happens regardless if I connect it directly or through any of my three (3) different externally powered USB hubs.

I had this before for USB Memory sticks as well, but re-installing drivers helped.

What do I do now?

  • Please clarify what iTunes version you are installing and whether it is 32-bit or 64-bit. Same for your Windows version. What OS and whether you are running 32-bit or 64-bit. I'm running W7 64-bit with iTunes 12 64-bit. I did the same WinRAR suggestion, but removed AAS.msi since that is 32-bit and repaired AAS64.msi, since that is the one I need for W7 64-bit. – Sun Feb 8 '15 at 4:38
1

I removed Citrix which was installed on my computer. See this link here: http://www.techsupportforum.com/forums/f10/solved-usb-hub-power-exceeded-767570.html

It now works.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .