5

I have a MacBook Pro, running Mac 10.9.5. I connect wirelessly to the Internet through my home Cisco LinkSys E900 router, which sits just 10 feet away from my computer. However, frequently when I leave my computer inactive for a period of time and then return after waking it from hibernation, my Internet is connect to an xfiniti Wifi hotspot, without my having done anything. How do I configure my Mac so that it will ignore the xfiniti Wifi hot spot and remain connected to my home network?

  • Do you ever want to use this "xfinity" hot spot? If not - remove it from Your prefered WiFi networks in Preferences -> "Network" -> "WiFi" -> Advanced... – Mateusz Szlosek Jan 27 '15 at 14:58
5

Looks like the computer is set to prefer or prioritise the xfiniti Wifi hotspot over you home wifi, you can set your home Wifi to be of priority to any other Wifi connection and this is how to do that,

System Preferences/Network/ then select Wifi and click on Advanced, you'll see all preferred networks there.

Click and drag your home Wifi to the top.

System Preferences/Network

  • 1
    If you remove it, it comes back. Automagically. – Sandwich Sep 3 '16 at 21:14
  • 2
    Because it's probably being synced over iCloud. – Maximus Sep 24 '16 at 20:41
5

There is actually more to this story than most of the answers here get into. I tried moving my office network to the top of the list, and my mac still always chose xfinity whenever there was one around.

At one point when trying to connect to xfinity on purpose, during the connection process it told me that it had to "upgrade xfinity connection" or something like that. It claimed it was in the name of security. What it did when I agreed to it was to install a "Profile." This created a new preference panel in System Preferences that was grouped along with Users & Groups and Startup Disk.

In this panel, there was only one option, Xfinity, and some text telling me yay how great it was. After removing this, my mac now honors the order of wifi networks in my Network Preferences.

0

You can change the order of connection to your preferred networks.

System Preferences -> Network -> WiFi

Then drag the Cisco Linksys E900 to the top of that list (making sure xfiniti is below it -- or remove it entirely).

  • When you say "to the top of that list", what list are you talking about? There are two select menus on the screen ("Location" and "network Name") both are single selects and neither permits dragging. – Dave Jan 27 '15 at 16:01
  • @Dave - this answer has a screen shot of where I mean: apple.stackexchange.com/a/169209/18529 – thornomad Jan 27 '15 at 16:09
0

Have home network first and xfinitywifi last. I'm guessing if the wifi signal is disrupted it will find xfinitywifi but won't go back when the home network signal returns.

0

I have had similar problems for a long time, where xfinity keeps edging out my wifi, which is six feet away from my computer. I do not want to remove xfinity because the removal process notified me that it would remove it from all my devices. But I do want it for my iPhone.

So this is a quandary.

-3

I had the same problem. In advanced preferences, I removed xfinity completely (twice). The problem persisted. My answer is conjecture, but this would seem to be a job for Apple tech. support...as they can show you how to install and use adware medic. I believe this is xfinity marketing in action.

  • This problem isn't specific to xfinity; I don't use them and I keep getting the same problem but with my ISP's public hotspot near my house. – Neil Fein May 26 '16 at 20:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .