31

Long story short, I am using Citrix to remote into my PC at work, and several applications require the use of the INSERT key, which, as everyone knows, Apple chose to eliminate from their keyboards. I've tried everything I can think of, and never been able to find an easy way to send this keycode via Citrix. I'm sure there are other uses for this, and I've read quite a few people's questions on the subject, but no one seems to have offered a viable solution.

I have the Apple USB keyboard (full-size, with numeric keypad), and in the position where the INSERT key would normally exist, Apple placed the "fn" key. Now, I still need this key from time to time, but what I'd love to see is perhaps Control-fn or similar to send the keycode for INSERT. If anyone knows how to achieve this, preferably without installing 3rd-party software (adware?), I'm all ears.

13 Answers 13

30

For Midnight commander it seem to be ^/Ctrl+T=Insert. As suggested by jherran.

The more generic Insert function is supposed to be Fn+Return/Enter=Insert, see this other question for more discussion and details.

I have however had little success with Fn+Return working reliably in many applications.

| improve this answer | |
  • Thanks, but no, that doesn't seem to work for me, either. As I mentioned above, I'm actually using Citrix, but it should be a fairly generic key-mapping. If one doesn't exist, I'd appreciate knowing how to create a custom key binding. – Dave Jan 28 '15 at 20:31
  • It does not work in LibreOffice for Mac – DanielBlazquez Jan 6 '19 at 22:20
6

You can follow this post which suggesting to use Karabiner app to simulate Insert key with the following configuration of private.xml file (edit in Misc tab):

<?xml version="1.0"?>
<root>
  <item>
    <name>Fn + Ctrl-Left to Insert</name>
    <identifier>private.fn_ctrl_to_insert</identifier>
    <autogen>
      __KeyToKey__KeyCode::CONTROL_L, ModifierFlag::FN,
      KeyCode::PC_INSERT
    </autogen>
  </item>
</root>

and then enable newly created item after reloading the file in Change Key tab.

To find out the right key code, use EventViewer in Misc tab.

| improve this answer | |
3

fn + i worked for me and it enabled insert on my latest mac book pro terminal.

| improve this answer | |
  • This was the solution for me on MACOSX High Sierra – user293639 Jul 2 '18 at 17:23
2

The only combination I have found is Ctrl + A.

Edit: macOS Sierra

| improve this answer | |
1

Get non-apple external keyboad.

| improve this answer | |
  • 3
    Downvoted into oblivion, but yes, this is probably the most generic - if not all to obvious - solution to this problem. In case all else fails, get another keyboard. – Maarten Bodewes Jul 17 '17 at 11:15
1

I've been succesful with fn + tab key in some apps.

Give it a try and good luck!

| improve this answer | |
0

I use Citrix and I have the same issue, can't figure it out. only thing I found is if you have the external keypad, press clear to turn numlock off, then press 0 and it works as insert

| improve this answer | |
0

Just in case somebody is looking for the answer for MacOS Sierra (with 2017 Macbook Pro), please try: Fn+Ctrl+Enter

| improve this answer | |
0

You can do this by using the following keyboard shortcut:

fncontroloption

| improve this answer | |
0

In iTerm2, you can remap any key under Preferences... -> Profiles -> Keys -> +. For the insert key, select as Action "Send Escape Sequence" and as value ESC + [2~.

On my keyboard, pressing the Insert key appears to trigger the "Help" action, so this is what I remap. This works for instance for Midnight Commander.

Remaping Insert in iTerm2

Alternatively, you can try to edit ~/Library/KeyBindings/DefaultKeyBinding.dict and insert a line like

"\UF727" = insertText:;

(See NSEvent.h for the left-hand side and this for the right-hand side of this setting.)

| improve this answer | |
-1

fn + tab works as the insert key in the Freeplane mind map software

| improve this answer | |
-2

try "fn+command+v", and let me know too :)

| improve this answer | |
  • What do you expect Fn-Cmd-V to do? – nohillside Jan 23 '19 at 6:50
-3

From an iMac running OS 10.8.5 with an extended usb keyboard using Microsoft Remote Desktop to control my PC (Win 7), I can use shift-control+0 (keypad) to send the enter key.

| improve this answer | |
  • ‘to send the enter key’? OP is looking to simulate Insert, not Enter – grg Oct 18 '17 at 20:50

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .