Long story short, I am using Citrix to remote into my PC at work, and several applications require the use of the INSERT key, which, as everyone knows, Apple chose to eliminate from their keyboards. I've tried everything I can think of, and never been able to find an easy way to send this keycode via Citrix. I'm sure there are other uses for this, and I've read quite a few people's questions on the subject, but no one seems to have offered a viable solution.

I have the Apple USB keyboard (full-size, with numeric keypad), and in the position where the INSERT key would normally exist, Apple placed the "fn" key. Now, I still need this key from time to time, but what I'd love to see is perhaps Control-fn or similar to send the keycode for INSERT. If anyone knows how to achieve this, preferably without installing 3rd-party software (adware?), I'm all ears.


14 Answers 14


For Midnight commander it seem to be ^/Ctrl+T=Insert. As suggested by jherran.

The more generic Insert function is supposed to be Fn+Return/Enter=Insert, see this other question for more discussion and details.

I have however had little success with Fn+Return working reliably in many applications.

  • 1
    Thanks, but no, that doesn't seem to work for me, either. As I mentioned above, I'm actually using Citrix, but it should be a fairly generic key-mapping. If one doesn't exist, I'd appreciate knowing how to create a custom key binding.
    – Dave
    Commented Jan 28, 2015 at 20:31
  • It does not work in LibreOffice for Mac Commented Jan 6, 2019 at 22:20
  • Ctrl+T works for me
    – ivan.ukr
    Commented Nov 27, 2022 at 22:45

fn + i worked for me and it enabled insert on my latest mac book pro terminal.

  • This was the solution for me on MACOSX High Sierra
    – user293639
    Commented Jul 2, 2018 at 17:23

You can follow this post which suggesting to use Karabiner app to simulate Insert key with the following configuration of private.xml file (edit in Misc tab):

<?xml version="1.0"?>
    <name>Fn + Ctrl-Left to Insert</name>
      __KeyToKey__KeyCode::CONTROL_L, ModifierFlag::FN,

and then enable newly created item after reloading the file in Change Key tab.

To find out the right key code, use EventViewer in Misc tab.

For Karabiner Element 11.1+, they've changed the config file to karabiner.json, so the modifications would become:

    "profiles": [
            "complex_modifications": {
                "rules": [
                        "description": "Fn + Ctrl-Left to Insert",
                        "manipulators": [
                                "from": {
                                    "key_code": "left_control",
                                    "modifiers": {
                                        "mandatory": [
                                "to": [
                                        "key_code": "insert"
                                "type": "basic"

See also the doc for the available keys and the semantic for the modifiers.


In iTerm2, you can remap any key under Preferences... -> Profiles -> Keys -> +. For the insert key, select as Action "Send Escape Sequence" and as value ESC + [2~.

On my keyboard, pressing the Insert key appears to trigger the "Help" action, so this is what I remap. This works for instance for Midnight Commander.

Remaping Insert in iTerm2

Alternatively, you can try to edit ~/Library/KeyBindings/DefaultKeyBinding.dict and insert a line like

"\UF727" = insertText:;

(See NSEvent.h for the left-hand side and this for the right-hand side of this setting.)


I use Citrix and I have the same issue, can't figure it out. only thing I found is if you have the external keypad, press clear to turn numlock off, then press 0 and it works as insert


The only combination I have found is Ctrl + A.

Edit: macOS Sierra


Get non-apple external keyboad.

  • 4
    Downvoted into oblivion, but yes, this is probably the most generic - if not all to obvious - solution to this problem. In case all else fails, get another keyboard. Commented Jul 17, 2017 at 11:15
  • 1
    This is great advice, but in 2020 doesn't work. I have a bog-standard USB PC keyboard into a macbook via a dock and the insert key does nothing, not the dedicated one nor the one on the 0 key of the num keypad. I tested with xev which shows no activity at all when pressing Insert.
    – Criggie
    Commented Mar 8, 2021 at 3:52
  • It's not a keyboard issue, it's about the system. The Insert key simply does nothing, even if it's present on a keyboard. Commented Dec 22, 2023 at 8:11

I've been succesful with fn + tab key in some apps.

Give it a try and good luck!


Just in case somebody is looking for the answer for MacOS Sierra (with 2017 Macbook Pro), please try: Fn+Ctrl+Enter


For sublime text, you can use optioncmdo (oh, not zero).


fn + tab works as the insert key in the Freeplane mind map software


You can do this by using the following keyboard shortcut:



try "fn+command+v", and let me know too :)

  • What do you expect Fn-Cmd-V to do?
    – nohillside
    Commented Jan 23, 2019 at 6:50

From an iMac running OS 10.8.5 with an extended usb keyboard using Microsoft Remote Desktop to control my PC (Win 7), I can use shift-control+0 (keypad) to send the enter key.

  • ‘to send the enter key’? OP is looking to simulate Insert, not Enter
    – grg
    Commented Oct 18, 2017 at 20:50

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .