6

There's "ghostet text" in my terminal (see screenshot), and I'm hoping someone knows how to fix this…

Ghostet text in terminal, OS X Yosemite 10.10.1, background opacity 75 %, integrated graphics

Turning background transpareny off fixes the problem, but it's not a solution which I'm a fan of.

I tried cranking the opacity up to 100 % (thus turning transparency off), ran some commands, and turned the opacity back to 75 %, which made the ghosting appear yet again.

I love working in the terminal, and really hope someone have a suggestion for a fix :)

Specs which might be relevant:

  • OS X Yosemite 10.10.2
  • Macbook Pro 8.1 (early 2011)
  • Integrated graphics
  • Using TotalTerminal 1.5.4
4
  • I guess I'll ask the obvious question. Are you sure that's not whatever is behind the window showing through?
    – Kenster
    Jan 28 '15 at 21:59
  • Yes, I'm certain it's a shadow of the terminal output – it happens no matter the background, and I deliberately used a purely white background for the screenshot :)
    – AllanLRH
    Jan 29 '15 at 9:17
  • 1
    And here I was, thinking it was "just" the usual image retention on my retina MacBook Pro… I suppose it has something to do with the way TotalTerminal renders the pane? Maybe you could post this on the binary forums too?
    – Asmus
    Feb 22 '15 at 21:04
  • 1
    FYI: Found this thread on their forums, where users complain about the same issue, but no fix yet.
    – Asmus
    Feb 23 '15 at 21:42
2

More recently in the thread linked to above, the developer of TotalTerminal replied:

darwin - Sep '15

TotalTerminal is not going to work on El Capitan without System Integrity Protection disabled. That is why I stopped developing it and switched personally > to iTerm2. I'm sorry, but I won't fix this one.

http://discuss.binaryage.com/t/text-burn-in-when-using-transparent-backgrounds-since-yosemite/2849/11

So it looks like we're out of luck, at least for now. I've noticed the ghosting for a while, and right now I'm actually running TotalTerminal on El Capitan (with SIP disabled I guess), and would love to keep using it, but it sounds like I'll have to take it with this little wart or not at all.

3

This one helped me:

Open your Terminal preferences, go to Profiles > Window > Background (Color & Effects), and set a light blur.

I use 30% to keep anything in the background from disturbing the readability of thin fonts on an already translucent window, so I never noticed the "burn-in" effect when moving to Yosemite.

Source: http://discuss.binaryage.com/t/text-burn-in-when-using-transparent-backgrounds-since-yosemite/2849

However I set blur to 1% and "ghost" text disappeared.

4
  • Doesn't fix the problem on my machine :(
    – AllanLRH
    Feb 24 '15 at 17:59
  • Today I turned on my computer and see that it's returned.. Sorry, this answer is not valid :( I set blur to 30% and it stopped to annoy me so much, but it still appears. I'll continue to trying find out the solution.
    – sennoy
    Feb 25 '15 at 13:22
  • I've spent quite a lot of time to check/uncheck all possible things and try everything non-dirty to fix this. Everything that I can suggest to you - clear screen before slide-up your terminal. Ghost text appears only when you slide-up with tab full of text, then slide-down and change to another tab.
    – sennoy
    Feb 26 '15 at 8:26
  • Blur doesn't help, just blurs more the ghost text so it increases the readability. Would they fix that? Jun 18 '15 at 19:04

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .