2

Somewhere after Lion (from which I upgraded to 10.10), Apple has changed the shortcut to show/hide the toolbar in Preview from -B to -I, at least it says so in the menu entries. enter image description here But when actually using the shortcut, what pops up is (as one would expect), the info window. enter image description here

Can someone explain why they would change it (probably not a constructive question), or whether this is a bug and how to rectify this and get the old behaviour back? Can this be done with assigning custom keyboard shortcuts?

7

This is not a bug, although I can certainly see why it looks like one. That little symbol is a pipe ( | ), not the letter I. The pipe is the upper character on the backslash ( \ ) key.

So to type -|, the physical keys you need to press are: -Shift-\.

The difference between "|" and "I" was more pronounced back when Lucida Grande was the system font (in fact, this very post is set in Lucida Grande; you can see how the pipe is taller and thinner than the uppercase I). But OS X Yosemite switched the system font to Helvetica, and unfortunately the "|" and "I" now look basically identical.

  • +1 Darn it. I swear I tried it as a pipe and it did not work. But of course it does now. :-O. Think I must have forgot to hold down shift. (tired brain) – markhunte Jan 27 '15 at 0:48
  • Oh god, so simple! They should've left it on Cmd-B. – oarfish Jan 27 '15 at 6:22
0

As @daGUY spotted it is a pipe "|" symbol.

But you can change it to the old short cuts.or any other that does not clash, by using the keyboard shortcuts in system Preference -> App Shortcuts.

But note: I could not get it to pick up if I assigned new shortcuts to Preview.app (Show Toolbar & Hide Toolbar ).

In the end I assigned the + B for both to All Applications which Preview.app picked up

  • It's strange that one has to assign it for both All applications and Preview in particular, any idea why this is? – oarfish Jan 27 '15 at 6:23
  • @oarfish No I could not figure that out. For some reason it did not want to know. It could be just my app as I had played with it in the past. Does the same definitely happen for you. – markhunte Jan 27 '15 at 12:22
  • For me it suffices to set it for All Apps, but for Preview alone is not enough. Weird. – oarfish Jan 27 '15 at 13:26
  • Would be interesting to know why this was down voted? – markhunte Jan 30 '15 at 22:32
-1

This is probably a bug, or you've changed it yourself. Report to Apple and look with them.

You can change this by going to System Preferences -> Keyboard -> Shortcuts -> Application Shortcuts and add what you want, you will have to type the exact thing such as "Show Toolbar".

I can't see for myself if it's a mistake on Apples part because I'm using Swedish on my OS X.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .