0

I am attempting to clear the "form & search history" in Firefox, and the box is completely grayed out and will not allow me access.

enter image description here

Any thoughts or suggestions about how to fix this?

1

This happens when the item (in your are the "Form & Search History") is already cleared.

Are you sure this is not your case?


You mentioned in you comment that Firefox autofills the search bar when you type a website. Do you mean the URL bar (also known as Awesome bar ) ?

If yes, then the described behavior is expected. The Awesome bar get its results from "bookmarks, history and tabs".

So if you want to remove urls that you previously typed, you have to clear your browser's history.


On the other hand, if you mean the actual search-bar: enter image description here

Then right click on it and select "Clear Search History" or select the option you mention in the question.

On the image above the "stack" word is a search I have previously done. You probably don't have any, since they are cleared.

For more information on what each option on the "Clear Recent History..." means check this section.

  • I don't believe so, because Firefox is still autofilling the search bar when I type in websites. – Nate Jan 26 '15 at 19:40
  • There is probably some confusion between the search bar and the url bar. Edited my asnwer. Check and let me know :-) – LyK Jan 27 '15 at 15:24
  • thank you! your additional link is what helped me find my issue. – Nate Jan 27 '15 at 21:45
0

The add-on BetterPrivacy is interfering, when this add-on is disabled, you can clear history again. It is reported at Bugzilla per Juli 2015, hopefully someone is working on it there...

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .