2

iTerm2, on startup, opens as many tabs as were opened in my previous session. How can I disable this behaviour? I don't need those empty tabs.

2

1 Answer 1

2

Close all windows and tabs, except only one, or arrange windows and tabs the way you want, and then:

  1. Windows > Save Window Arrangement
  2. Preferences > Arrangements > Set default
  3. Preferences > General > Startup and Select Open Default Window Arrangement

PS: iTerm restores all sessions when you disable the Close windows when quit app in System preferences

2
  • i tried it. one terminal with restored tabs and one with default arrangement were opened. "Close windows when quit app" is enabled
    – wedens
    Jan 27, 2015 at 13:21
  • check the file in ~/Library/Saved Application State/com.googlecode.iterm2.savedState
    – nelson
    Jan 27, 2015 at 13:53

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .