1

When entering an email address into the To: field of Mail, usually the full name of the recipient is displayed instead of the actual address. When entering my own address, however, I get the following:

Weird descriptive text

Any idea how I can make it display may actual name instead of my beloved holiday destination?

1 Answer 1

1

Create a contact with your name in Contacts app and add your email to that contact.

Seems like you have such a contact but with name Holidays in Italy instead of yours.

In case you have that email in your Mail app, then make sure you have the desired name in the "Full Name" field of the account. One way to do that is via "System Preferences" -> "Internet accounts" -> select your account and then click on the "Details" button


I think those descriptive names comes from either a contact or some previous emails in the Mail app.

Click the '+' sign at the end of the "To:" field and (in the popped-up search field) start typing the email address as you would before. Check the results there.

If nothing is found again, then try typing the "Holidays in Italy" and see if it finds something.


The options above are mostly a way to find why this is happening.

If you just want to remove the description every time:

  • click on the little arrow next to "Holidays in Italy"
  • select "Edit Address"

You can also select "Show Contact Card" (if available) to check things. Another option could be "Remove from Previous Recipients list". In that case you can select it in order not to have it being auto-filled again.

4
  • Thank you for your answer. Unfortunately, your hints did not solve the issue. My own contact details seem alright as well as the account properties in the mail.app. Interestingly, a spotlight search does not return any results when looking for Holidays in Italy. I can't figure out where the system takes it from and how it got there in the first place.
    – symphonic
    Commented Jan 27, 2015 at 14:24
  • I edited my answer to provide some extra cases. Let me know!
    – LyK
    Commented Jan 27, 2015 at 15:45
  • I fixed it using your suggestion of removing it. Now the name is indeed taken from the contact information. Clicking on the '+' sign did not reveal anything new, though.
    – symphonic
    Commented Jan 27, 2015 at 16:44
  • I guess that suggests that it was taken from some old email you sent or received. Glad it worked out :)
    – LyK
    Commented Jan 27, 2015 at 19:09

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .