0

I am having problems changing the Permissions on the "username.conf" file in the /etc/apache2/users/ folder. It needs to have the permission of
-rw-r--r-- 1 root wheel 298 Jun 28 16:47 username.conf
but I am not able to achieve this.

I have tried changing the permissions with the command
sudo chmod 644 username.conf;
and it didn't change.

I am using this tutorial: http://coolestguidesontheplanet.com/forbidden-403-you-dont-have-permission-to-access-username-on-this-server/

When I check the permission of the file, it's
-rw-r--r-- 1 root wheel 155 Jan 23 23:30 Owner.conf

When I navigate to http://localhost/~Owner/ , I get 404 Not found.

  • At the beginning of your question, you show the file info and permissions of "username.conf", then later show the file info and permissions of "Owner.conf". Make sure that you are looking at the same file... – Chris Mukherjee Jan 26 '15 at 0:32
  • @ChrisMukherjee Owner.conf is my version of the username.conf. The username.conf is from the tutorial. – Oscar A. Peña Jan 27 '15 at 1:02
  • The username should be the short username, which is all lowercase. What happens if you change the file name to owner.conf, and try to access localhost/~owner ? – Kent Jan 27 '15 at 6:28
1

The permission command chmod 644 is actually working!

The permission of your file Owner.conf is -rw-r--r--.

The chmod command works by specifying (1) the permissions for the file owner - in this case root, (2) the permissions for anyone in the same group as the file owner - in this case the group is wheel, and then (3) the permissions for everybody else (global permissions).

For each of the three above groups of users, the possible permissions are read, write, and execute. Full permissions would look like this: -rwxrwxrwx.

The permissions are specified using binary notation. 1 means the permission should be set, and 0 means it should not be.

Thus, setting chmod 644 sets permissions 6 - or 110 in binary - for the file owner, and 4 - or 100 in binary - for the group and for everybody else.

This creates the permission string -110100100. This translates to: -rw-r--r--.

Note that in your question above, the username.conf and Owner.conf both do have permissions of 644.

  • Then why my .conf file is not 298 like the tutorial conf file. Why is it I cannot navigate to localhost/~Owner Thanks – Oscar A. Peña Jan 28 '15 at 0:17
  • 298 is the size of the file. Your file is 155 MB, and the tutorial file is 298 MB. The tutorial mentions a 403 error, which is a permission error. You are getting a 404 error, which means that the file is not found. Are you sure that your Owner.conf file is in the right directory? – Chris Mukherjee Jan 28 '15 at 3:47
  • Ok, I thought that it was the permission code. the conf file is in the apache2/user folder. Here is the httpd file, my conf file, and the httpd-user – Oscar A. Peña Jan 30 '15 at 1:07
  • Edit to my comment above, the file sizes are in Bytes, not MB. – Chris Mukherjee Jan 30 '15 at 16:03
  • I'm sorry, but I'm not willing to do all the work for you. As far as this question goes, I feel as though I have answered the question in a sufficiently clear and detailed manner. If you have a new question, feel free to ask a new question (though I believe that stackoverflow.com might be a better fit for your questions). I would advise you to take the time to do some research online first to see if the solution to your problem already exists. Best of luck! – Chris Mukherjee Jan 30 '15 at 16:07

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .