2

When I originally got my iPhone 5s I asked Siri to set my home address. At that time, it recognized a wrong address and I can't seem to find a way to correct it. It is listed with a little house icon as my home address within my recent listing of addresses but not sure how to correct it. My iPhone (which I recently updated to an iPhone 6) does recognize "me" as my correct contact information within contacts. My contact information does have my correct home address and when I ask Siri what my home address it is does list my contact information but when I say "take me home" it goes to the historic wrong address.

I've read prior posts and one suggested it might be pulling from my AppleID but that isn't the case. It's listed right there.

I can't seem to find where this information is editable? The only place where I can find where it seems to be stored is within the iPhone/Apple "Maps" application.

I've cleared the history in the application and it clears everything but the home so can't seem to find a way to get rid of it or change it (swipe to left or right doesn't seem to work easily).

As stated, I now have an iPhone 6. It's running iOS8 but has the same problem on my 5s when it was running iOS7.

Please help, I find this frustrating and haven't seem to find any posts that help.

2

Don't know if you've figured this out yet, but I finally did today. I've had the same problem for years and multiple phones. Today I opened my contact info and as always, my home address was correct. I clicked on edit and down at the bottom, under my home address was an "other" address, the one maps always tried to take me to. I was able to delete that address and it fixed my problem!

Also - be sure to check if you have many sources to contacts. Facebook, work or exchange contact lists, google contact lists, etc.. can all link and pull an address that's somehow indicated as "home".

The steps to clear up contacts when contacts only exist locally or only in one cloud database is:

1

I had to unlink my Facebook 'me' contact from my regular 'me' contact, then re-link them. That solved my map problem.

0

Your home location on Apple Maps is linked and shown as the "Home" address on the Contact you have set as "yourself".

You can change what Contact is "yourself" by tapping Settings > Mail, Contacts, Calendars > My Info and choosing a Contact in your list.

0

You should only need to update your own contact information for yourself in your contact list. Note: you will see "me" shaded gray to the right, next to your own contact name. Make sure your current address is updated and delete the old address.

0

I had this issue too. Checking my addresses (and as others, I have a number of linked accounts), I noticed one that had the right streetname and number, but no city information. From the small map excerpt shown next to it, I could see it was matched to a street in a completely different city. The moral is that if the problem is not obvious, make sure you very carefull at each entry under your own entry in the address book.

-1

Go to your contacts and where your details are listed at the top, edit and then update your address.

  • Welcome to Ask Different. We like answers to be more than just a single line. Ideally, you want to explain why your answer is *right." It also helps to provide links, citations, and/or screen shots. Please review our help section How to Answer on writing good answers to questions – Allan Jul 9 '16 at 22:04

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .