0

The issue I'm having is that I manage three Mac Mini servers. Two are for work, one is for me. I can log into our main work server and my personal box using WebDAV, however, the second work server rejects my login credentials with "The user name or password was not accepted by the server." errors.

The two work computers are pretty much mirrored in every way possible. The notable exceptions are the network (one is one city, the other a different one). Work server #1 is an Open Directory Master, the other is a replicant. The hardware is slightly different.

Server #1 is running 10.10.1; Server #2 is running 10.10.2. Both are running Server 4.0.3.

If I try to log into both servers through AFP or SSH, there are no problems. It's only when we try to access Server #2 that we're having issues on all accounts (both local and network users).

I believe WebDAV broke during a recent Server update, however, I can't pinpoint when that occurred.

Any help would be greatly appreciated.

  • Are you able to log in to the second server with other protocols besides WebDAV? – douggro Jan 25 '15 at 17:57
  • Yes. SSH, SFTP, AFP, all work perfectly fine. – Daniel Jan 26 '15 at 21:03
  • You might try disabling then re-enabling WebDAV on the affected server, then monitor the logs to see what's happening when you try to connect to the WebDAV share. – douggro Jan 27 '15 at 6:58
  • Tried restarting WebDAV to no avail. The problem seems to be that a client device can connect through the protocol, however, when the credentials are checked, the server doesn't accept them. We've tried three different test accounts, some local and some network accounts without effect. – Daniel Jan 28 '15 at 7:39
  • My instincts are telling me that the problem is tied to the OD replica status of the problem server, rather than being a problem with WebDAV. Is OD running as replica-only or a Master-replica on the problem server? – douggro Jan 28 '15 at 8:00
-1

With OS X Yosemite 10.10.2, WebDAV is only accessible via HTTPS.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .