2

I have two languages I am actively using. English is my default, but in some applications such as Skype I use Russian. Every time I am switching from Skype to Safari I have manually switch back from Russian to English and this is annoying. How can I configure so that language switch is handled by operating system automatically when I am changing windows?

In Keyboards->Input Sources I've ticked Automatically switch to a document's input source but it doesn't work, still if I've switched to Russian it will stay while I will change it again.

I am on Yosemite 10.

Thanks for any help!

marked as duplicate by nohillside Jul 9 '17 at 16:08

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • I don't know about automatically switching but you can set a keyboard shortcut to change input source. It's in System Preferences > Keyboard > Shortcuts > Languages & Text > "Select next input source". The default is command+space, but you can change this. Simply press the specified keys when switching to Skype to switch between English and Russian. – Arc676 Jan 25 '15 at 2:04
1

Here's what I'm experiencing on El Capitán...

The key here is "document's input source" so when switching from Skype to Safari, if no document (web page in this case) has focus the input source will not change. If you then select, for example, a field on a page, the input source should change to whatever the last input source was when you were last in that document. So one application program can have multiple documents each with its own input source and the OS won't switch input sources until a specific document within the app has been selected.

If you open a new safari window or tab, the currently active input source will be used for that new "document."

  • 1
    Good find about the inputs. But still, the feature feels a little bit off.. Doesn't seem to be keeping up to the expected result.. – Gio Feb 21 '17 at 7:08
0

The Automatically switch to a document's input source works, but not like you think it should.

It's intent is to switch the keyboard to input method you choose, which it does, however it only does it will the application is active. So your using Skype and you move over to Safari it will switch based on the documents input method, then you go back to Skype it will switch to Russian again, however once you quit Skype it will default back to your systems primary language. An alternative would be to click on the Show Input Menu in Menu Bar where it will display an icon and the languages you elect and choose from there as opposed to diving into System Preferences every time.

So Go to System Preferences > Keyboard > Input Sources > Show Input Menu in Menu Bar

This is an alternative, as far as an autonomous option, someone who is well versed might be able to help you with a command line reference. Theres not really anything in automator that can help you out beside running an apple script or shell script, but still you will need a keyboard shortcut to active those

Not the answer you're looking for? Browse other questions tagged .