The Fn keys don't seem to work on my Macbook Pro when it's runnign windows 7 Under bootcamp. I can't turn the volume up or down or mute the sound etc.

I've found articles leading to me to believe that I can do this using the bootcamp entry in control panels but I've had no luck doing this. all it seems to change is whether I have to press the Fn button to get the normal behaviour of the F keys. E.G. whether I have to press Fn and F5 to refresh the page of just F5.

I think there is a driver issue with Windows 7 as people seem to have gotten them to work under XP.

  • Did you actually read the Boot Camp Installation Guide?
    – user6124
    Jul 3, 2011 at 11:36
  • Yes, the option in the bootacmp control panel doesn't enable the Extra functionality of the buttons just changes whether you have to press Fn to get their normal functionality. Jul 4, 2011 at 7:42

4 Answers 4


bootcamp.exe should launch upon Login. Sometimes it doesn't or at least it doesn't stay running. You can log out and log back in or try the following, it worked for me:

Open Task Manager and see if bootcamp.exe is running. If not, open C:\Program Files\Boot Camp with Windows Explorer and launch bootcamp.exe.

Function keys will work again.


I was having a similar problem and just finally got it fixed. Heres how I did it:

  1. Update everything on the Mac side. I mean actually go over and make sure everything is updated, not just assuming it is via the 'Apple software' updates you get in windows... (I found about 14 updates windows had not updated for the Mac side of things)

  2. Ensure Windows is fully updated. (This should be pretty easy to do, but again, double check.)

  3. Get Boot Camp 3.3

  4. Enjoy having your function keys back. (And the backlit keyboard, the real reason I missed it all.)

I also noticed during this time that the boot camp icon is gone(no longer showing in system tray, even though it is supposed to be shown constantly). You may be able to just skip to step 3 and be done with it, but it never hurts to fully update everything anyway... :)

  • Thanks, I'm abroad and have a really slow net conection but I'll download the updates and come back to say if this solves the issue. Sep 2, 2011 at 9:02

It does sound like a drivers issue. Have you tried updating to the latest Boot Camp Drivers for Windows 7? The latest seems to be Version 3.2.

Make sure you grab the correct version (32 bit or 64 bit).


  • I've got 3.2 installed, I checked the apple update client and it said everything was up to date, then I downloaded 3.2 (64 bit) off of the apple website and it said that a newer version was already installed. Jul 4, 2011 at 7:43
  1. Look in your task bar for Boot Camp, it should appear as a grey diamond.
  2. Click it and select "Boot Camp Control Panel..." (click YES to UAC if activated)
  3. Select Keyboard tab
  4. Make sure "Use all F1, F2, etc. keys as standard function keys" is checked in the checkbox.
  5. Click Apply and OK. You will now have your function keys as primary without needing a restart.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .