1

I have a Seagate Free Agent HDD drive with NTFS formatted. Since there was trouble with writing to NTFS partition in Yosemite, I've installed OSXFUSE from dmg package and ntfs-3g from homebrew and it becomes writeable.

But, I've noticed, that every time, I connect the hard drive, It mounts to the new folder.

OSX will normally create a directory/folder as the mount point in the /Volumes/ area for a drive. When you unmount the drive, the system should also remove all references of the mount point from /volumes/. I.e the folder it created.

But in this case when I unmount my drive the system is not clearing the mount point folder it created in /volumes/

for instance here is output of listing Volumes folder:

$ ls -l /Volumes/
total 16
d--x--x--x+ 3 root          admin   102 Jan 24 12:57 FreeAgent Drive
d--x--x--x+ 3 root          admin   102 Jan 24 13:01 FreeAgent Drive 1
drwxrwxrwx  1 nikolaygolub  staff  4096 Jan  9 01:35 FreeAgent Drive 2
lrwxr-xr-x  1 root          admin     1 Jan 24 12:50 LV -> /

As you can see the old mount point folders still exist and each new one increments with a number increases.

I've tried to remove all folder after disc ejecting, but it didn't help. I've noticed following messages in log file:

24/01/15 13:02:10,654 ntfs-3g[782]: Version 2014.2.15 external FUSE 27
24/01/15 13:02:10,654 ntfs-3g[782]: Mounted /dev/disk3s1 (Read-Write, label "FreeAgent Drive", NTFS 3.1)
24/01/15 13:02:10,655 ntfs-3g[782]: Cmdline options: volname=FreeAgent Drive 2,local,negative_vncache,auto_xattr,auto_cache,noatime,windows_names,user_xattr,inherit,uid=501,gid=20,allow_other,nodev,noowners,nosuid
24/01/15 13:02:10,655 ntfs-3g[782]: Mount options: volname=FreeAgent Drive 2,local,negative_vncache,auto_xattr,auto_cache,allow_other,nodev,noowners,nosuid,allow_other,nonempty,noatime,default_permissions,fsname=/dev/disk3s1,blkdev,blksize=4096
24/01/15 13:02:10,655 ntfs-3g[782]: Global ownership and permissions enforced, configuration type 1
24/01/15 13:02:10,764 fseventsd[20]: failed to make the directory /Volumes/FreeAgent Drive 2/.fseventsd (5/Input/output error)

How can I fix this? It looks like a minor issue, but I don't want to periodically clean up folders after OS.

I want to achieve normal behavior for mounted NTFS drives: I want to be able to write to them and I don't want to manually delete folders, created during automount. I don't have any problems with that in OS X Mavericks.

P.s. Yosemite is the worst OS X ever.

1

Firstly you should not need any extras to mount NTFS drives.

You do not make it clear what you want to achieve.

I have an old FreeAgent I used for Windows backup. I DON'T want it to automount, so I have the following in etc/fstab see edit detail below

#
# Warning - this file should only be modified with vifs(8)
#
# Failure to do so is unsupported and may be destructive.
#
UUID=E00F307A-9295-482E-8A79-2FA2C922F3CD none ntfs rw,noauto
⋯
LABEL=Tempy none ntfs rw,noauto

I can use DiskUtility to mount if I want to access these.

If you want to auto mount in a specific directory you can create an entry to do this. If you do create a directory and edit fstab.

NOTE you should use vifs, which requires a knowledge of vi commands, so you should look at man vi to discover the basic commands.

 :q! quits
 :wq saves 
  i to insert
  • I've updated the question. I still want to have hdd mounted automatically, but what should I do with undeleted folders? – Nikolai Golub Jan 24 '15 at 11:12
  • So long as nothing is mounted to them, you can delete the folders. If you add an entry to /etc/fstab as suggested you can force the OS to always mount to one specific folder, which you will have to create manually beforehand. – XQYZ Jan 24 '15 at 11:23
  • As @XQYZ says you need to create the folder. I haven't actually done this for years, because it usually isn't necessary in OS X, but there does seem to be a problem with duplicate folders. You need an entry like above replacing none with mount point, and noauto with auto – Milliways Jan 24 '15 at 11:31
  • It might be worth trying to just delete the folders before you mess with fstab. Unplug the device, clear out the old folders and then test around if it works now. Maybe OSX just detects that the folder already exists and that's why it is creating new folders. – XQYZ Jan 24 '15 at 11:49

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .