4

This question already has an answer here:

For the past several days, I have been unable to install ANY apps onto my iPad. When I click "GET" and then "INSTALL", it just says "Waiting..." below the app icon.

This is what it looks like (not from my iPad, from Google):

enter image description here

I've tried the following to attempt to resolve the issue:

(I had no other apps updating/installing)

  • Restarted the device
  • Turned on and off the device
  • Updated the iOS 8 software to latest version
  • Went to Settings>General>Reset>Reset All Settings
  • Restarted AppStore
  • Synced my device with iTunes
  • Deleted app and tried to reinstall
  • Logged out of Appstore
  • Logged back in to Appstore
  • Turned off/on wifi

In addition to not being able to download apps, I can't download books from iBooks either. I don't know if this is a software issue, or if it's a network issue.

marked as duplicate by bmike Aug 31 '15 at 1:04

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 1
    I'd try on another connection - starbucks etc. I think it's network, I've had similar issues in the past. [or try over 3/4G, if it's capable] One thing I did in the past was to remove all restrictions on my router from 17.x.x.x - Apple owns the entire subnet – Tetsujin Jan 24 '15 at 8:20
0

You could try doing a hard reset of your iPad.

Press and hold together the home button and the on/off button on the side of your iPad for a few seconds. This will make your screen go black and bring up the Apple logo. There is no need to do anything else. Device will reset itself and turn back on. This usually does the trick.

Not the answer you're looking for? Browse other questions tagged .