5

It happens after I get a new macbook for work. This is a Macbook Pro(Retina, 2012) with OS X Yosemite. I created a new user, and checked 'click or tap with two fingers' for the 'Secondary click'. However, the right-click menu doesn't show up when I tap or click with two fingers, nor if I right click an external mouse. I have to right click twice, very quickly, either on the trackpad or an external mouse, in order to get the pop-up menu.

This is really annoying and I haven't found any solutions online.

Update 1: I changed the 'Secondary click' setting to something else and then back to 'click or tap with two fingers'. And now everything works expect for Google Chrome. I still have to double-right-click on a webpage in Chrome to bring up the menu. However, interestingly, on the tab bar and tool bar, etc., (i.e., everywhere except for the webpage itself in Chrome), a single-right-click works...

  • is the field/app/item already front-most when you do the first click? Mac has always traditionally used the first click as 'bring to front' unlike Windows which will action a click even if that app was backgrounded. – Tetsujin Jan 23 '15 at 19:44
  • Thanks @Tetsujin for replying, please see my Update 1. It is already front most. – warriormole Jan 23 '15 at 21:06
3

I uninstall Chrome extension "crxMouse Chrome Gestures" and install Smooth Gestures Plus and its plugin SmoothGesturesPlusExtras. Solve my problem but the extension isn't free.

| improve this answer | |
  • crxMouse Chrome Gestures was the cause of the same issue for me as well. But my love for mouse gestures outweighs my annoyance with double-right-clicking! – Steven Nov 15 '16 at 17:50
1

Check whether you have the SmoothGestures plugin installed. This is a known issue.

You can navigate to chrome://extensions/ and disable SmoothGestures to see if it fixes the issue.

Source: https://productforums.google.com/forum/#!topic/chrome/PlsuvMGbi_o

SmoothGestures has released an additional plugin to work around this issue. http://www.smoothgestures.com/installplugin.html

If the problem is not the SmoothGestures plugin, check other Chrome plugins to make sure they aren't changing the mouse behavior either.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .