1

I get a popup "The contents list can’t be created for compressing." every time when I try to compress a file.

And also thumbnail preview is not working.

I am sure if both issues are related but they both happened today.

I've tried repairing disk permissions, deleting finder plist, restart but none of this works.

I am running Yosemite 10.10.1

Any suggestion?

=================================

I went to Apple Store and they can't fix this. They reinstall the Mac for me.

Thanks for all answers.

  • is it the same file or any file? – Ruskes Jan 23 '15 at 4:48
  • ACLs issue perhaps? Though idk how to clear them in Terminal, I'd use Cocktail etc. – Tetsujin Jan 23 '15 at 7:51
  • @Tetsujin Thanks. Just tried Cocktail but it didn't help. – pt2121 Jan 23 '15 at 14:56
  • What are you trying to compress ? [on Unix all is file] However, you can put your "file" into a directory and compress this one. – StrawHara Jan 26 '15 at 2:54
  • @MrMojoRisin Thanks I can still compress a file from command line: zip and tar. I was able to do it with the right-click until the day I asked the question. (And I know I can put a file in a "directory" and compress it.) – pt2121 Jan 26 '15 at 2:58
3

Run the following commands in order in Terminal. Same issue for me and fixed it. I'm not sure what's causing it but I have to run it every so often to fix it.

sudo mkdir /private/tmp
sudo chmod 0777 /private/tmp
0

Try downloading The Unarchiver on the App Store and create the zip file with that. If that does not work go into your terminal and type killall Finder. That terminal command should deal with the thumbnail issues and hopefully the archiving problem as well.

0

Usually, this is because you don't have enough disk space left on the drive you're creating your backup.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .