69

My macbook pro running Snow Leopard stopped making sounds a couple hours ago. I've found other reports of people with sounds working through headphones, but that's not the problem I'm seeing. I get no sound when my headphones are plugged in either.

I'm wondering if there's a LaunchAgent or LaunchDaemon to restart which would remedy this. I've already tried killing the coreaudio daemon (and it dutifully automatically restarted) but that didn't fix it.

I need to reboot for an OS update, so I think that'll probably rectify things.

Is there another way?

  • I'm fairly new here but can ask a question that might help. Have you have recently updated to 10.6.8? Many users are reporting audio issues as well as problems with networking and printing after updating to 10.6.8. You may need Apple to issue a patch or you could try some of the interim solutions people are suggesting for these 10.6.8 issues. – bg2011 Jul 1 '11 at 22:54
  • When this happened, I was on 10.6.7. After I restarted, I'm now on 10.6.8. – Doug Harris Jul 2 '11 at 12:34
  • Sound came back after a reboot. – Doug Harris Jul 2 '11 at 12:34
  • @Doug I wonder if there was an update that installed after you rebooted.... – daviesgeek Dec 29 '11 at 23:22
  • No, just rebooted without any system updates – Doug Harris Dec 30 '11 at 15:40
136

You can kill the CoreAudio process by opening Terminal and running sudo kill -9 `ps ax|grep 'coreaudio[a-z]' | awk '{print $1}'`. It will restart automatically after a couple seconds.

That fixes some problems my aging MBP has been having, where it sometimes fails to detect headphones or decides the speakers aren't connected. No guarantees it will work for every audio problem, but it's worth a shot.

Source: zakgreant on macosxhints forums.

  • 1
    Thanks this helped! I just had to kill the core audio service. It restarted after a few seconds. – Moussa Apr 10 '13 at 3:06
  • <3 This also works on Mavericks!! :))) – OZZIE Feb 21 '15 at 9:59
  • 29
    sudo pkill coreaudiod – berto Mar 7 '16 at 18:12
  • 2
    Worked for me on High Sierra (10.13.2). – Mike Collins Feb 12 '18 at 19:04
  • 1
    Worked for me on High Sierra (10.13.6). And I wonder why this problem prevails even after it is 7 years now from the question has been firstly asked.. – Ramvignesh Apr 26 at 9:10
27
sudo kextunload /System/Library/Extensions/AppleHDA.kext 

sudo kextload /System/Library/Extensions/AppleHDA.kext

These two commands will unload then reload the audio kernel extension.

  • 2
    Nice, worked for me on Mavericks. – Bombe Feb 28 '14 at 22:08
  • Just crashed my comuter (OSX El Capitan)... I would not recommend it, though I guess it worked after restart :-p – Carles Estevadeordal Dec 11 '15 at 13:31
  • This crashes my macOS Sierra 10.12.1. I do not recommend using this fix. – ejmin Nov 15 '16 at 13:05
  • Works on my old iMac (Snow Leopard) when it fails to recognize my USB sound card. Previously a reboot was needed to fix this, so neat! – Ákos Feb 25 '17 at 10:08
  • 3
    This actually worked with me on OSX Sierra (whereas the most popular answer did not) – rburhum Nov 13 '17 at 19:37
7

I am on 10.9.2 and have the same problem. Since there are two answers, I wanted to document my findings:

sudo kextunload /System/Library/Extensions/AppleHDA.kext 
sudo kextload /System/Library/Extensions/AppleHDA.kext

These two commands will unload then reload the audio kernel extension. This post fixes my problem 100% of the time, So please upvote that original post

This solution did not work for me:

sudo kill -9 `ps ax|grep 'coreaudio[a-z]' | awk '{print $1}'`

It shuts down the internal speakers and sends the sound to my 27" monitor but does not bring back the sound to my internal speakers or headset. Perhaps in some cases it works, but hopefully this post might explain when to use one solution vs the other.

  • 1
    Apple High Definition Audio kext? Neat, I would not have figured that acronym without this context. – Jason Salaz Apr 3 '14 at 7:26
  • IMHO, the 'kill -9 `ps ax|grep 'coreaudio...' should always work without the need for a reboot. The restarted coreaudio daemon may pick an audio device which it finds first (no idea how the audio device is selected in that case), but you can reset to the wanted audio device by 'System Preferences...' -> 'Sound' settings. Also, for a browser session, you might need to select the appropriate audio device as well. – huch Nov 6 '18 at 7:11
3

So apparently 8 years later macbooks still suffer from the same problem, as I encounter it quite often when plugging in headphones.

The command to fix this right away:

sudo pkill coreaudiod

  • 1
    This answer was already provided. You'll be subject to downvotes until you either delete the answer or add additional, supporting, or new info that hasn't already been provided. – fsb Aug 16 at 13:14
  • I scrolled through the main answer list and there were only the more complicated commands. But indeed this answer is somewhere in the comments. It seems stupid to delete it though. – Joel'-' Aug 20 at 9:36
  • On this site, if you can provide additional info to an existing answer, and you have enough reputation, you can edit that answer to add that info. Your answer here is a good example of that opportunity. You don't have to delete your answer but, as I mentioned, you're risking receiving downvotes because of it. – fsb Aug 20 at 13:09
2

In my experience, a reboot is required to fix this. It's a poor fix since it seems to recover from the failure and not address the root cause. I would like to have, but have not yet discovered if there is another quicker/simpler method to get sound back...

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .