Can anyone advise on how to stop this happening.

The external monitor attached to it goes black for a few seconds but then comes back to show the Desktop etc.

When I boot into Windows 7 64 bit Pro (via Boot Camp) this never happens. So I don't think it's a hardware issue.

Please advise.


Removed OS version from title as issue occurred in several versions. Added versions where seen as tags.

It never happened with Mavericks (but did following the upgrade to Yosemite, went away, then came back after a while after upgrading to El Capitan (I think) but also Sierra).

  • This does seem to be a problem. To narrow this down a bit. Nov 15, 2015 at 4:27
  • Charles Merriam: "This does seem to be a problem." - yep sure is - so by that do you mean it is also a problem for you? "To narrow this down a bit" - how do mean? Are you asking me to provide more detail, provide analysis? What? Or are you going to do it? Can you add a further comment rewriting what you intended to say, since as it stands what you've said adds no value I'm afraid. Thanks. Nov 15, 2015 at 12:38
  • Ah, I had a detailed point. Unfortunately, StackExchange timed out on entering it as a comment and apple.stackexchange.com/users/9058/patrix deleted the answer version of the write-up. Sorry, you are on your own. Nov 16, 2015 at 17:05
  • Ah OK unlucky thanks for trying @CharlesMerriam appreciate that. I see the problem through a KVM so maybe wcc's answer is a good lead. Nov 17, 2015 at 10:45
  • @CharlesMerriam I asked apple.stackexchange.com/users/9058/patrix why your post was removed and he responded: twitter.com/nohillside/status/667255472337108992 - "Post didn’t answer the question, non-answers usually get removed. Please ping me in chat for further discussions" Nov 19, 2015 at 8:42

3 Answers 3


I did have this with my Mac Air and it was a bad cable.

I replaced it and then it would crash, if that happens try this:

system prefs > security > advanced > uncheck logout after xx minutes of inactivity

Someone on this site suggested it for display crashes and it worked beautifully for me.

  • +1 thanks wcc. I'm using it via a KVM so your point about cable may be related, in that the signal path through my KVM may not be the best quality for the less robust display drivers in MacOS (compare with those in Windows on the same machine) Nov 17, 2015 at 10:46
  • I'm going to accept this answer, because I replaced the cable setup with a cable with a good review rating on amazon and the problem now never happens. I am running up to date macOS sierra now also. To give detail on what I changed regarding the cable: I had a mini display port to DVI adapter to which a DVI cable attached and the other end the KVM. I still have the KVM (by startech) but now have the "high quality" DVI cable instead of the adapter and other cable. I also have the logout setting switched off as wcc described. Dec 4, 2016 at 16:50
  • I noticed that the original issue occurs with certain apps particularly with flash video and some apps that use Qt C++ libraries e.g. BBC iplayer in chrome (flash), Beyond Compare (Qt C++) and Adobe (Qt C++ I think). I would imagine that these apps are making use of the hardware acceleration more than other apps and so were more sensitive to the cable not being adequate. But now, the problem doesn't occur as said. It has gone away before though but hopefully this time it won't come back, the only risk is I can think of is a macOS update that introduces regression. Dec 4, 2016 at 16:52
  • What seems to be clear, is that this is not a hardware fault with the mac but rather the cables and or power management configuration. Dec 4, 2016 at 16:53
  • (I also cleared the PRAM and SMC (via the respective key presses sequence on start up - see official Apple knowledge base articles), this may have contributed to the solution, as well as the steps described above) Dec 30, 2016 at 16:25

This solution worked for me on Macbook Air (Early 2015) - Catalina

"Having spoken with Apple they recommended turning off completely and holding Cmd+Alt+P+R and turning the power on. once you press the power button, keep holding the four buttons and you should hear the startup tone, then you will hear the tone again."

Source: https://forums.macrumors.com/threads/external-display-randomly-goes-black.601565/post-22383921

  • Didn't work for me
    – Jorj
    Dec 3, 2020 at 6:54

I don't know if your problem has been solved but you can simply start by running a power on self diagnostic. To do this: reboot and hold "D" while starting up. If you have a firmware password enabled, then this will do nothing. You will need to disable that first. You can try resetting the SMC and NVRAM/PRAM. This may fix your issue. If this continues, try reinstalling the version of macOS that came with your computer. This will reinstall necessary drivers.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .