3

Suddenly, My MBP sound isn't working. I have tried couple of way to resolve the problem but nothing is working. Here is some of the screenshot:

sound

sound 2

No, input or output sound. I would like to know

1) How can I resolve this?
2) Can you suggest any software, that can route my sound in iPad/iPhone.

Update:

After running this command :

kextstat > ~/Desktop/kexts.txt

I got only this com.apple.iokit.IOAudioFamily But, didn't found com.apple.driver.AudioAUUC

Update - 2:

As Buscar suggested to check for AudioAUUC.kext file in my /System/Library/Extensions. Yes, I found AudioAUUC.kext file in that folder. As you can see in the image No indicates, it's not loading.

enter image description here

LOG UPDATED: http://pastebin.com/Qgj0WcpC

New Log: http://pastebin.com/R2RPZZZN

Update - 3:

As suggested to Resetting the PRAM didn't worked. I was able to update SMC and not EFI Firmware. It's showing an error:Software is not supported on my system. enter image description here

However, I also tried to load and unload Apple High Definition Audio (HDA)AppleHDA.kext. But, while loading this error are showing

1/24/15 8:29:57.000 PM kernel[0]: Sound assertion in AppleHDACodecGeneric at line 1280
1/24/15 8:29:57.000 PM kernel[0]: Sound assertion in AppleHDACodecGeneric at line 1580
1/24/15 8:29:57.000 PM kernel[0]: Sound assertion in AppleHDACodecGeneric at line 1073
1/24/15 8:29:57.000 PM kernel[0]: Sound assertion in AppleHDACodecGeneric at line 1073

Update - 4:

enter image description here

As you can see com.apple.audio.sandboxhelper is missing.

update - 5:

I tried all the things, you said to do. But, still I can't hear any sound. I tried ioreg -i. But, i couldn't find anything called AudioAUUCDriver. You can check here

http://pastebin.com/8uC6jLn7

Update - 6:

Guys, I can hear sound through a application called PocketAudio. My microphone and speaker both are working!! I just want to know, is there any problem in my hardware or in OS? If I buy a wireless headphone, should it work?

enter image description here

  • I did a fresh install. But, it didn't worked :-( @Buscar웃 – Adnan Jan 21 '15 at 6:15
  • 1
    Turning the computer completely off, waiting 30 seconds, and starting it again did not help? – Thorbjørn Ravn Andersen Jan 21 '15 at 8:33
  • 1
    OK, now it would be interesting to see your console log from the moment when restart and then some 50 lines after that to find out why that driver is not loading or any other relevant messages. You can copy paste in here or use pastebin, dropbox links. – Ruskes Jan 21 '15 at 17:26
  • 1
    Look for the AudioAUUC.kext file in your /System/Library/Extensions. If it is there (and it should be) than your I/O kit driver is not working properly. – Ruskes Jan 21 '15 at 18:48
  • 2
    Do you actually hear the start up chime (sound) or not? – Ruskes Jan 25 '15 at 20:42
2

Something killed your coreaudio drivers, or the sound hardware/motherboard.

I would suggest to do following order of investigation (Fixes)

  1. Open Activity monitor and look for following: (use sort by "Audio")

coreaudiod

If found use terminal to reset the coreaudiod

sudo killall coreaudiod
  1. Copy/paste following in Terminal to find out if the audio drivers are loaded

    kextstat > ~/Desktop/kexts.txt
    

    That will output a text file to your desktop. Use any text editor to search for "Audio"

    You should have the

    com.apple.iokit.IOAudioFamily   com.apple.driver.AudioAUUC
    

As reported the result is: AudioAUUC.kext is not been loaded?

  1. Lets try to load it manually using Terminal sudo kextload /System/Library/Extensions/AudioAUUC.kext/

UPDATE:

Based on new information I would suggest following (still trying to find out why your Audio is not loading in the profile.

  • Resetting the PRAM. Hold Down Cmd-Opt-P-R

Keep Holding until you have hear the "startup sound twice". If you do not hear the system sound then, you are on mute or your sound card is broken.

To un-mute use sudo nvram -d SystemAudioVolume

Test for start up sound!

  • If not run ioreg -i and look for the AudioAUUCDriver <class AudioAUUCDriver, id 0x1000003af, registered, matched, active, busy 0 (0 ms), retain 5> (use Edit - Find AudioAUUCDriver)
  • In safe boot, It was shows same as normal boot. I run AHT couple of time, But it didn't show any problem. When I run AHT first time, only that time i heard the startup sound. But, after that it has gone. – Adnan Jan 21 '15 at 6:37
  • Installing additional applications like Soundflower won't help in case of hardware issues – nohillside Jan 21 '15 at 9:20
  • Yeah, Sound button button isn't grayed anymore after installing SoundFlower. But, Still no sound!! – Adnan Jan 21 '15 at 9:28
  • We don't know what the problem is, but your answer suggests "killed" coreaudio drivers (which a reboot should fix) or hardware. In both cases adding an audio routing app won't help – nohillside Jan 22 '15 at 7:14
  • 1
    Answers shouldn't be used to "guess the problem", please use comments or chat for that – nohillside Jan 23 '15 at 16:06
1

In order to diagnose a hardware vs. OS error, try starting from external bootable media. The easiest way to do this is using a Linux Live CD. This allows you to start a totally separate, different and self-sufficient operating system. If you can get sound through that, it means the problem lies within your Mac OS X setup.

You can download a disk image here: http://www.ubuntu.com/download/desktop

If you can't or do not want to burn a CD or DVD, you can also make a USB drive. This can be automatically done using UnetBootIn (see: http://unetbootin.sourceforge.net ). You will need a fairly big USB drive and it will be formatted so make sure you have no files on it you want to keep.

I am suggesting Linux here because we also need to rule out a OS X-specific problem. Of some sort of EFI, HDA or OS X IOReg communication or matching failure causes CoreAudio not to load or to function properly, reinstalling OS X or booting form an external OS X drive might not help with further diagnostics.

  • I tried with Live Ubuntu. No Sound!! – Adnan Jan 29 '15 at 12:32
  • If you are willing to try one more thing, boot Ubuntu again and open a terminal. Run: lspci and post the output here. It should show the devices that are detected. If the sound card is there, we can go on from there. If it's not, you have a hardware problem. – John Keates Jan 30 '15 at 5:47
  • Output => pastebin.com/nCFGHw0Z – Adnan Jan 30 '15 at 11:50
  • Okay, the PCI device is there, which makes sense since it's integrated in the Intel chipset. High Definition Audio Controller however might not exactly be the chip you only want: a Cirrus or Maxim audio chip is supposed to be there as well. Does PocketAudio still work? – John Keates Jan 30 '15 at 13:56
  • 1
    In that case I'm running out of ideas. Sounds to me that part of the HD Audio bus has come loose. – John Keates Feb 4 '15 at 19:37

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .