Most likely after installing/(and since removed) Parallels my Apple IR Remote stopped working.

I've confirmed that it's not the battery (using the built in camera) and later tried it on another mac (where it works as it's supposed to).

Is there any tricks to restoring IR functionality without restoring the whole machine?

  • 2
    Make a new admin account on the mac to ensure it's not a user setting on the existing account. You will have to re-visit the security pref pane in the new user to see if it's workable there. – bmike Jul 1 '11 at 15:19
  • While the suggestions for answers were good, the solution was actually to replace the hard drive/ir cable assembly - which fixed the IR-sensor. – andy May 3 '12 at 11:04
  • It is not only ok, but encouraged to answer your own question. Selecting your answer is good since it signals that the question is resolved. – bmike May 3 '12 at 13:00

Check your System Preferences -> Security pane, on the General tab, to make sure that the IR remote functionality on your machine isn't disable. If it isn't disabled try pairing the remote with the machine by clicking the Pair... button and following the on screen prompt.

System Preferences, Security, General tab

| improve this answer | |
  • Has been tried... also tried while logging in as admin. From System Preferences everything looks alright (also tried repairing etc. to no response) – andy Jul 1 '11 at 14:05

A SMC reset is recommended for issues like this. Maybe it helps you out?

If this didn't help you out, you could try to repair your permissions.

| improve this answer | |

While the suggestions for answers were good:

the final solution was actually to replace the hard drive/ir cable assembly - which fixed the IR-sensor (and a few other undiscovered latent issues).

All in all, a hardware issue, not a software issue.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .