How can I permanently disable the startup sound (or chime) in Yosemite?

(I am using a late-2014 13" macbook pro)

I already tried several options found here and there :

  • installed StartNinja.app => did not work

  • installed Auto-Mute.app => did not work

  • tried to install the old StartupSound prefPane => did not work

  • tried the command "sudo nvram SystemAudioVolume=%80" => volume does not change (I also tried other values than 80, such as 00, 01, or nothing)

NOTE: I know that it is possible to mute the next startup sound by turning the volume down, but this is not a permanent solution.

  • 'Did not work' is not enough information to diagnose the problem. What happens if you run sudo nvram SystemAudioVolume=%80? (Note the capital V)
    – oarfish
    Jan 20, 2015 at 11:11
  • 1
    I gave some precisions: 80 or 00 or 00 or " " do not change the volume. The capital V did not change anything either.
    – fffred
    Jan 20, 2015 at 12:47
  • @oarfish, note that, I also tried to set the variable SystemAudioVolumeDB, without success, because it resets automatically to %eb on reboot.
    – fffred
    Jan 20, 2015 at 14:42
  • So what does the Terminal say when running the command? Any kind of error? Or does it set the parameter correctly but simply does not do anything (i.e. check whether the command did anything at all by running sudo nvram -p | grep SystemAudioVolume or so)
    – oarfish
    Jan 20, 2015 at 15:57
  • 7
    Apple must be very proud of this damn chime. sudo nvram SystemAudioVolume=%80 worked before Yosemite. And not it stops working. I happen to have an iMac27 with quite loud speakers, and large size itself. So I can't sneak it to another room just to boot it. And I risk waking up the whole family at night or early morning just because of this sound. This together with many other small things fed me up with Apple. My next computer will not be an Apple. Aug 3, 2015 at 6:40

9 Answers 9


I would like to suggest a little script that I wrote to solve this problem without hacking the system.

The idea is that the boot sound is not played if the Mac was muted before shutting it down. So this script basically mutes the Mac right before the shutdown and restore its previous state after login.

It should work on any version of OS X, and I tested it on my MacBooks with Yosemite.

You can find it on GitHub: https://github.com/teored90/nobootsound

The README tells you how to install the script. I hope this works for your system and I'd like to hear your feedback.

  • 4
    Decided to use this when nothing else would work for me. Works like a charm, and I like the philosophy behind it. Jun 1, 2015 at 19:21
  • This is a nice solution if I boot back into OSX. I get muted if I boot in another OS like Windows or Linux. And the same way, if I unmute when I am in another OS and want to boot back again! Aug 3, 2015 at 6:47
  • @bio yes in your situation you have to find another way. I can't think of any simple solution to make the script work with boot camp Aug 3, 2015 at 15:42
  • This is absurd. Is there no way to just delete the sound file or disable or reassign the sound to nothing like you can in Windows instead of having to do a ridiculous muting workaround??
    – user124384
    Sep 16, 2015 at 20:05
  • Nice script - I do that manually once after an OS X upgrade. - mute - reboot Mac - unmute - next reboot is also silent. Nov 19, 2015 at 15:58

Found this on Apple discussions.

To disable type in terminal:

sudo nvram StartupMute=%01

To enable replace 01 with 00.

Work for me on MacBook Pro 15 mid-2015, macOS Mojave

  • This should most likely work. It works in newer OS too.
    – Skyline X
    Oct 28, 2021 at 21:53

Try this in Terminal:

sudo nvram SystemAudioVolume="%01"

then restart. Cuts out the chord completely on my Yosemite Mac.


sudo nvram SystemAudioVolume=" "

(That's a single space character between the quotes. This plays the startup chord at a substantially reduced volume level.)

  • 2
    Thanks for the answer, but I tried both commands, and they did not work.
    – fffred
    Jan 20, 2015 at 8:27
  • Note: you can check sudo nvram SystemAudioVolume to see the current value.
    – mwfearnley
    Feb 19, 2020 at 9:16

I liked and used a similar Login/logout script to what Pincopallino suggested on Yosemite & Maverick, but for some reason only the logout script works for me on El Capitan.

I tested the scripts without logging out and in first, they seem to work. Not sure why loginhook is not working. Permissions are set to octal mode:755, user:root, group:staff (I wonder if it should have been wheel now or something.)

I tried editing the ttys file thinking maybe the loginhook was not working in El Capitan, tested it, then reverted the ttys file when it didn't make a noticable change after restarting.

Using a .plist file in /Library/LaunchAgents is working for me though.

I would have commented on Pincopallino's answer but don't have enough points to do that.

Here's an example .plist for those interested that would hypothetically work with the teored90/nobootsound installation package that Pincopallino linked to. I tested it to make sure it does indeed work.

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple Computer//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
  1. Open the terminal and paste the below command. The command touch creates an empty file on your desktop. The open command tells TextEdit to open the new empty file. Go ahead and paste the above code into the empty plain text file and save it.

    touch ~/Desktop/com.YourUserName.nobootsound_loginhook.plist && open ~/Desktop/com.YourUserName.nobootsound_loginhook.plist -a TextEdit
  2. Copy and paste the next command into terminal, hopefully you will only need to enter your password once. This command changes the permissions of the .plist so that it can be executed, and moves it to where it needs to be

    sudo chmod +x ~/Desktop/com.YourUserName.nobootsound_loginhook.plist && sudo chown root:wheel ~/Desktop/com.YourUserName.nobootsound_loginhook.plist && sudo mv ~/Desktop/com.YourUserName.nobootsound_loginhook.plist /Library/LaunchAgents

Logout and log back in, test, see if it works. I'm thinking about forking teored90/nobootsound, it'd be the perfect first experience for me to learn.

If it's not working and you want the .plist gone copy and paste below into terminal one last time:

sudo launchctl unload /Library/LaunchAgent/com.YourUserName.nobootsound_loginhook.plist & sudo rm /Library/LaunchAgent/com.YourUserName.nobootsound_loginhook.plist

Please remember to replace all instances of "YourUserName" with your actual username.

  • Thank you for the interesting post. The approach is interesting (and probably more modern), but, as far as I understand, this is only for the login part, right? You still need the logout hook. Anyway, have you tried the latest version of the script with El Capitan? Now it should be working correctly (at least it does on my system). Apr 3, 2016 at 23:14

In the past with all the Macs and OS (even 7/8/9) it worked when setting Volume to 0 for all sound options (system beep, output for Sosumi etc.) while logged in. I rebooted and voila - no sound during boot. After the Mac came up again, I set the volume to my favourite level, tried a reboot again and still no sound.

I never found out why there is such a behaviour. :)

  • 1
    And as far as I remember, hitting the no-sound key on the keyboard for a long time during poweron also set the startup sound to 0. Don't ask me why... :) Jan 20, 2015 at 16:04

This just worked for me (Mac Pro Tower, Yosemite): http://www.maintain.se/cocktail/

I'm crossing my fingers. It still made the startup sound on the first re-start, but I have restarted several times since with no sound. Pretty exciting if it continues to work. I haven't purchased it yet, just downloaded it in demo mode, but will happily pay the $20 if the results are long term.


Since all of a sudden, for no apparent reason, I have the same problem, I was forced to find a solution for myself. I stumbled upon this unix.SE thread. It recommends creating a script to run at shutdown like this (e.g. in a file named silence.sh):

#!/usr/bin/env bash

nvram SystemAudioVolume=%80

Then adjust the permission of the file sudo chown root silence.sh; sudo chmod u+s silence.sh; sudo chmod o+x silence.sh. Then set it as a logout hook: sudo defaults write com.apple.loginwindow LogoutHook /path/to/silence.sh. It seems to work for me.

Edit: Doesn't work for me after all (first time must have been coincidence), but maybe it works for others.

I therefore used the script to mute my sound on logout

osascript -e 'set volume with output muted'

It's ridiculous that I have to unmute my laptop every time, but better than this insane boot chime.

  • "set-user-ID-on-execution" (chmod u+s) has no effect on shell scripts
    – nohillside
    Jan 22, 2015 at 9:18
  • @patrix Might be, I don't know anything about file ownership and permissions on unix, I simply copied the instructions which helped me. If you are sure (or can confirm) that this really is not needed, feel free to edit this answer.
    – oarfish
    Jan 22, 2015 at 10:04

Can't comment under OP since I have <50 rep, but wanted to add that Onyx has this option: Parameters > Login > Startup Sound.

It does not work though for me under 10.10.3. FileFault 2 enabled, not sure if that could be interfering. If I reset the PRAM (start mac and press cmd + alt + p + r and let the start chime ring 3 times), then disable startup sound under onyx, the next time I restart, there is no startup chime. But if I restart a second time, the blaring sound is back.

Really wish, apple would make this an option under System Preferences > Audio. This can be highly disturbing and unprofessional depending on your environment. Yeah, never shut off your mac, but you now, shutting off your computer devices can be a healthy thing.

Edit: On MacUpdates StartupChimeMute surfaced today. But fails for me, just as Onyx did.

  • Note: StartupChimeMute does not work on my computer.
    – fffred
    Jun 5, 2015 at 13:08

sudo nvram SystemAudioVolume=%80

This worked for me on latest El capitain version.

  • 1
    This adds nothing that hasn't already been said.
    – Tetsujin
    Nov 19, 2015 at 13:51

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .