I am able to rearrange the dock icons for a period of time after each restart, though I have not been able to determine the length of time. Then I am not able to rearrange the dock icons again.

I have tried the solutions found here: Can't rearrange Dock icons

The killall Dock command did not do anything.

Deleting the com.apple.dock.plist file only seemed to work due to the restart because after a while the issue came back.

Is there a way to fix this issue so that I do not have to restart every time I want to rearrange icons?

  • do you have a ton of start up apps?
    – soulshined
    Jan 19, 2015 at 0:37
  • No I do not. I believe only chrome.
    – TronicZomB
    Jan 19, 2015 at 0:43
  • What happens if you log into another account..?
    – markhunte
    Jan 22, 2015 at 20:11
  • @markhunte Logging out and logging back in fixed it, but I don't know for how long that will last. It may be a similar temporary fix like restarting.
    – TronicZomB
    Jan 23, 2015 at 2:11
  • Perhaps it's the same issue: apple.stackexchange.com/questions/151522/…
    – StrawHara
    Jan 25, 2015 at 12:53

16 Answers 16


Did you try this?

Finder and Dock issues in OSX 10.10.1

I had the same exact problem and it was definitely caused by Pushbullet extension in Chrome. Disabled completely the extension, restarted the system and the dock started working. Don't know if it was caused specifically by the "Universal copy & paste" option being enabled or the extension as a whole, would have to investigate this further. Hope this helps.

  • This seems like it might be the most probable. I did have Pushbullet with universal copy/paste activated. Due to the restart it is working but I will give it one day to make sure it continues to work.
    – TronicZomB
    Jan 24, 2015 at 17:56

In Terminal.app type:

defaults read com.apple.dock contents-immutable

If it comes back with 1 then

Make a backup of the plist file and then try this command to unlock the Dock?

defaults write com.apple.dock contents-immutable -bool no; killall Dock
  • I did not know about that. I just tried it with true and it does give the sort of behaviour the OP is seeing. The only thing is the first time I used it it corrupted the plist. Luckily I knew to just move the plist to trash logout and back in. Which created a new one with the original setting I had. (I normally create a backup :-) first but this should not have corrupted the file?)
    – markhunte
    Jan 22, 2015 at 18:33
  • I have updated your answer to include a test first and to backup the file
    – markhunte
    Jan 22, 2015 at 18:37
  • Unfortunately all that did was cause my dock to restart and get set back to defaults, the icons were still locked. I still had to do a restart in order to move the icons & folders back to where I wanted them.
    – TronicZomB
    Jan 22, 2015 at 18:54
  • Ah, not good if it corrupted the plist. I tried it and it was fine, but thanks for adding the test. So was the test you did before the executing the second command positive or negative? And by "set back to defaults", do you mean the positions of the apps in the dock revert to old positions? Could the plist be being overwritten with an old copy from somewhere?
    – Bootle
    Jan 22, 2015 at 19:00
  • you can use @TronicZomB to make sure they see your comments
    – markhunte
    Jan 22, 2015 at 20:08

Seems that pushbullet is the culprit (thanks @mysz). Specifically the chrome extension for pushbullet, uncheck universal copy and paste by visiting the extension's setting page. Do a restart and the problem should be fixed


Is it possible you're unwittingly holding down the command key while dragging. The command key temporarily "locks" the Dock, so that drags to/from the Dock do not affect it. This is new in Yosemite. The purpose is two-fold:

  • When dragging a document to the Dock, it prevents icons already present from "dancing away" from the one you're dragging, making it easier to drop a document onto an app in the Dock.

  • When dragging a document from the Dock, it lets the Dock know you intend to drop it somewhere (such as on an application or into your Finder sidebar) and are not trying to remove it.

You might object "I would know if I were holding down the command key." But it's possible you are inadvertently enabling "Sticky Keys". By default, Sticky Keys is turned on/off by pressing the shift key five times in a row. This is easy to do if you are playing a game that uses the shift key as a fire button.

When Sticky Keys is turned on, tapping any of the modifier keys (command, control, shift, option) makes the modifier key "stick", even after you lift your finger from the key, until you press a non-modifier key. The purpose is to facilitate use of the computer by someone who can press only one key at a time.

Note that dragging something to/from the Dock is a mouse action, not a "non-modifier key", and does not release the sticky modifier.

Tapping a modifier key twice in a row locks it, similar to how Caps Lock works. The key behaves as if pressed until you tap it again to unlock it.

If Sticky Keys has become activated, it's easy to press the command key intending to invoke some keyboard shortcut, and then change your mind. You lift your finger from the key, but Dock (and all your other apps) think you're still holding the key down.

  • Excellent suggestion that was very likely. However, I checked and do not have sticky keys enabled unfortunately.
    – TronicZomB
    Jan 19, 2015 at 15:45
  • Not to belabor the point, but how did you check? If you went to System Preferences→Accessibility→Keyboard and saw no checkmark in front of "Enable Sticky Keys", that doesn't mean Sticky Keys is not enabled. It only means it's turned off right now. While looking at that preference window, tap the shift key five times and see what happens. (Buried behind the Options… button is a an option, turned on by default, to make the "tap the shift key five times" action a synonym for a click on "Enable Sticky Keys".)
    – ganbustein
    Jan 20, 2015 at 4:38
  • 1
    I checked all those areas and it is definitely not enabled. I wish that were the case, making this a quick solution.
    – TronicZomB
    Jan 20, 2015 at 4:47
  • same here....sticky keys is DEFINITELY disabled AND currently off..
    – mjrider
    Jan 21, 2015 at 17:39

Do you use an app, such as TinkerTool (http://www.bresink.com/osx/TinkerTool.html) to modify the way your system works?

TinkerTool Dock Settings

I had a similar problem, except that it wasn't time bound (to my testing). I simply couldn't re-arrange the dock icons, no matter what options I had selected (in TinkerTool).

Finally, I decided to reset the options in TinkerTool, logout, and log back in. This solved it for me.

TinkerTool reset area

If you haven't used any such apps, I think you could try downloading TinkerTool, playing around with the options it has for the dock, and finally, if nothing else works, do a reset of the TinkerTool options.

Note that I chose the option "Reset to pre-TinkerTool state" first, and immediately after I chose "Reset to defaults".

I hope this works for you as well!

  • I have not used TinkerTool. I can try downloading it and doing a reset to find out.
    – TronicZomB
    Jan 23, 2015 at 2:09
  • 1
    I reset to defaults then restarted and the issue came back later that day.
    – TronicZomB
    Jan 24, 2015 at 17:55

Just killing the com.apple.dock.plist from the finder may not work because the system holds the current settings in memory and will just write them back.

You could try and delete it from Terminal.app


Go to ~/Library/Application Support folder in Finder and remove the folder:

Dock (this holds a dock database )

Then in terminal type and run

defaults delete com.apple.dock.plist;killall Dock

  • I tried that and it still did not fix the issue. Thanks for trying to help.
    – TronicZomB
    Jan 22, 2015 at 3:06
  • @TronicZomB when you did this did the same icons come back in the dock or the default icons
    – markhunte
    Jan 22, 2015 at 18:20
  • The icons came back the same as before, not the defaults.
    – TronicZomB
    Jan 22, 2015 at 18:41
  • Which means it is still getting it from memory. The only way I have really done it in the past then is to kill the pref and hard reboot straight away. But I am not recommending that as it is drastic.
    – markhunte
    Jan 22, 2015 at 20:06
  • @TronicZomB But I notice you say you are now back to defaults in Bootle's answer. So if it was going to be fixed from that it would have been then.
    – markhunte
    Jan 22, 2015 at 20:11

If your issue is not resolved yet, I can come up with a series of things that might be happening but require some digging. You already commented somewhere that you found the solution in a Chrome extension, but if someone else arrives here with a similar issue but without using Chrome or an extension, this might prove useful.

First step is to check if this issue is system-wide or bound to your user account.

Make a new account via System Preferences, log out, and log in to the new account. Use the preinstalled Apple apps and see if the problem is still there.

If so, the issue has to do with something you installed and is running as an application or service in the background. It might also be something that hooked in to MCX which is a system designed for network administrators to make settings stick on computers.

If the issue is gone, it is only in your account. This means it is restricted to whatever applications are running when you log in, and any files and settings in your home folder. To figure out what is causing the problem, the following data is needed:

  • List of files in ~/Library/LaunchAgents (if this directory exists)
  • List of files in ~/Library/LaunchDaemons (if this directory exists)
  • List of items in the extensions panel in the system preferences
  • List of items in the Login Items in the Users & Groups panel (also sys prefs)
  • List of applications that you have set to automatically start when you log in on the dock

This gives a list of all he possible items that might influence the normal operation of the Dock. The ~/ is a shorthand for your user home directory. The ~/Library directory can be accessed from the Finder by holding the Option key (or Alt key) and clicking the "Go" menu and then the Library item.

The next bit of data comes from the Activity Monitor. When you log in, please open the Activity Monitor, find the Dock item in the list of processes and double click it. This opens the detail view on the Dock process. The third tab, "Open files and Ports" contains a list of files the dock has opened. Copy that list here (or use a pasting service like pastebin.com ), which will give us a list of all the files that the Dock is using. If there is anything in there that doesn't belong there, that would be the culprit.

Next bit of data would be form the system logs. Console is the application you can use to view the logs and get specific data using the searching and filtering options. What you could do is start it and keep it open, and as soon as the Dock locks up (not allowing you to move items), check to see if the logs are suddenly showing things related to the Dock, or any application you have open, or maybe sandboxd, OpenGL or WindowServer. Copy those lines (and again, if it is a lot of text a pasting service like pastern.com might be useful to not bloat your post) and that might tell us what is happening.

Not begin able to drag anything around inside the dock but having everything else working leads me to believe that either something is locking the icons down, which is a supported function in the Dock, or an external application is trying to interface with the Dock for some sort of functionality and it is doing something wrong and thereby breaking some functions. The Dock is more than just a Dock, it also manages certain aspects of window swithcing, application switching, mission control, launching services and if I remember correctly some clipboard functions.

After you have collected the data, you might be able to restart the Dock from the Activity Monitor by using the "Quit" button at the bottom of that detail window you opened by double clicking the Dock from the process list. Hint: to stop the process list form bouncing around, sort it by name.


Trying to rearrange Dock icons on 10.10.2 new MacBook Pro 13" Retina, I had this problem too. Accidentally hit on dragging while holding down fn key; huh? But it worked!


I’m using 10.10.3 on a mid-2010 15" MacBook pro, and found the same problem. It seems that clicking on a particular dock icon very quickly opens the pop-up “Options…” menu immediately above it, and the icon is frozen in place. However, if I’m quick enough, I can move the icon before that menu appears, and icon remains movable for as long as I hold the trackpad “click.” Is it supposed to work this way? Who knows? Worth a try if it avoids some of the more exotic solutions offered above.

UPDATE: I got around to stopping in at a nearby Simply Mac store to see if my approach worked on any of their machines. Before I could explain the "problem," the nice sales clerk proceeded to move a dock icon exactly as I had at home. Seems that IS the way it's suppose to work!


I do not have the "Pushbullet" chrome extension. For me it was a bit of misunderstanding and actually quite silly, I'm a developer and live mostly in the shell/terminal so I'm still quite unfamiliar with the GUI. I came from one computer (2012 Air) to my new computer

I wanted to remove some icons from the dock. I tried dragging them off, at this point a tooltip with the word "remove" would appear, when I let go the icon would just slide right back to my dock, "wut?".

My Solution

If an application isn't set to "keep in dock" then you won't be able to drag it off the dock, you'll experience what I mentioned above. All you have to do is... close the application, and it disappears off the dock.

My Case

I was trying to remove "chrome" from my dock since I use alfred to launch everything. I wasn't able to remove it, once I realized what I mentioned previously, it was a "duh" moment. I was then able to see that I could remove the apps from the dock that were indeed "locked" to it.


Hold down "fn" key, then drag icons on Dock to desired position.


I had this issue on my 2016 MacBook Pro 13". It had something to do with the haptic feedback trackpad. If I pushed firmly slowly, I noticed that it clicked twice and the second click shrunk the window (or said no windows available if the app I was trying to move was not live); this action would not let me move the icon. However if I press gently and move the icon quickly so would engage the first click, but not the second click, I could now move the icon. There may be some trackpad setting that I can have it turn off the hard and soft click but I am tired of monkeying with it for now.


click and hold the ALT key, then mouse click and hold the icon you want to move. Took me a couple of times before I got the icon moving, but it worked for me.


If you have a USB mouse connected and are also using an Apple wireless mouse, disconnect the wired mouse.

For me the problems went away when I did this.

The issue returned as soon as the USB mouse was plugged in again, even though not using it. I guess this could point to an issue with the generic driver software for the USB mouse?

This and other dock-related issues were driving me nuts:

  • unable to move dock items in Yosemite 10.10.5
  • unable to add dock items by drag and drop
  • dock autohide feature not working
  • item magnification not working unless mouse clicked
  • other weird behaviours.

I tried all previously suggested prefs deletions and resets without joy.


I was getting extremely annoyed with this but think I found a solution. After pressing the fn key, it started working flawlessly. Note I did not have to hold down the fn key but I just pressed it once and dragging/rearranging icons in the Dock worked.


I just changed Dock preferences from Genie effect to Scale effect an it fixed the problem.

  • We appreciate the extra information, however once you have 50 reputation, please post "Micro-answers" or additional information in the comments section. Alternatiely, you can explain more so other people understand too
    – John K
    Dec 22, 2015 at 23:27

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .