1

I'm experiencing a very weird network issue on my newish (2014) macbook pro. I've noticed it the last few weeks, but it could have been around longer, perhaps dating back to the Yosemite upgrade. I'm only getting to look at it now.

Mostly macbook works fine, but every now and again it stops talking to the internet. It seems to happen every 15-20 minutes, for a duration ranging from 30 seconds up to 5 minutes. It's mainly an issue for Skype, where I experience occasional disconnections.

I have run ping youtube.com and it reports Request timeout for <ip-address> at times corresponding to my outages. Note that it does not say No route to host.

I have also run ping against my router IP-address and this always works without fault. thus issues on wireless interface can be ruled out.

I have run ping on my actual router too, against the youtube IP-adress, and this reports no fault. this rules out actual service-provider network issues.

I have run ping from my iPhone, and this reports no problems so the issue is almost certainly something to do with macbook, rather than wifi devices in general.

Apple's wireless diagnostics utilities do detect the outages, but provide no solutions. The tools it provides also show no wireless congestion issues, and no problems with signal.

I've tried a whole slew of fixes:

  • disabling bluetooth
  • changing from 802.11g to 802.11n between 2.4GHz and 5 GHz and changing channels.
  • setting IPv6 to link-only
  • disabling handoff

I'm going to have a go at the PRAM reset thing if the issue becomes chronic again, and I really don't think I should have to resort to an O/S reinstall.

I would like to understand though, even theoretically what is going on here. It's driving me bananas!

  • Reading on this topic further I think it may have been the Yosemite 10.10.1 update that broke my computer! Hopefully it's the 10.10.2 on its way that will resolve my issue! – robert Jan 19 '15 at 11:18
2

I discovered that bouncing airport (Disable/Enable on Air Port Icon in the top right) resolved the issue temporarily.

Eventually I tried a PRAM reset and that seems to have fixed the problem for good.

Would have loved to understand the root cause though ...

There is a collection of fixes on reddit here, that people with similar issues might like to try: http://www.reddit.com/r/apple/comments/2jwah7/psa_yosemite_wifi_issues_list_of_possible_fixes/

  • 1
    resetting PRAM fixed the problem for me too!! – gannex Apr 20 '18 at 4:11

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .