I installed a windows 7 on macbook using bootcamp. Everything looks fine, but one thing. Here is stated that "Apple’s Boot Camp driver package automatically installs an HFS+ driver for Windows, which allows Windows to see your Mac partition. This partition shows up as “Macintosh HD” under Computer on your Windows system." But I don't see this partition. I tried to download and install bootcamp drivers manually taking them from apple page, but this didn't help. I tried to download HFS+ drivers, but when I install them the system sais that they are installed already.

Why I don't see the partition? Has apple changed this for yosemite?

Aditional info:

Model: MacBook Air (13-inch, Early 2014)

[22:57:27]~$ sudo diskutil list
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *500.3 GB   disk0
   1:                        EFI EFI                     209.7 MB   disk0s1
   2:          Apple_CoreStorage                         459.4 GB   disk0s2
   3:                 Apple_Boot Recovery HD             650.0 MB   disk0s3
   4:       Microsoft Basic Data BOOTCAMP                40.0 GB    disk0s4
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:                  Apple_HFS Macintosh HD           *459.1 GB   disk1
                                 Logical Volume on disk0s2
[22:57:28]~$ sudo diskutil cs list
CoreStorage logical volume groups (1 found)
+-- Logical Volume Group 7B2EDA4F-F3FF-4884-9253-D2170790ABD6
    Name:         Macintosh HD
    Status:       Online
    Size:         459418034176 B (459.4 GB)
    Free Space:   0 B (0 B)
    +-< Physical Volume C16CF9A0-A81C-4ED2-A6D4-CA4DF48AA0C6
    |   ----------------------------------------------------
    |   Index:    0
    |   Disk:     disk0s2
    |   Status:   Online
    |   Size:     459418034176 B (459.4 GB)
    +-> Logical Volume Family A05D294B-CCF6-4B21-9C91-B3E99E8B9D33
        Encryption Status:       Unlocked
        Encryption Type:         None
        Conversion Status:       NoConversion
        Conversion Direction:    -none-
        Has Encrypted Extents:   No
        Fully Secure:            No
        Passphrase Required:     No
        +-> Logical Volume 4BB22737-5EFB-49D6-ADF1-5B719538AF45
            Disk:                  disk1
            Status:                Online
            Size (Total):          459082489856 B (459.1 GB)
            Conversion Progress:   -none-
            Revertible:            Yes (no decryption required)
            LV Name:               Macintosh HD
            Volume Name:           Macintosh HD
            Content Hint:          Apple_HFS
[22:57:28]~$ sudo gpt -r show /dev/disk0
gpt show: /dev/disk0: Suspicious MBR at sector 0
      start       size  index  contents
          0          1         MBR
          1          1         Pri GPT header
          2         32         Pri GPT table
         34          6         
         40     409600      1  GPT part - C12A7328-F81F-11D2-BA4B-00A0C93EC93B
     409640  897300848      2  GPT part - 53746F72-6167-11AA-AA11-00306543ECAC
  897710488    1269536      3  GPT part - 426F6F74-0000-11AA-AA11-00306543ECAC
  898980024       1864         
  898981888   78123008      4  GPT part - EBD0A0A2-B9E5-4433-87C0-68B6B72699C7
  977104896        131         
  977105027         32         Sec GPT table
  977105059          1         Sec GPT header
[22:57:28]~$ sudo gpt -r show -l /dev/disk0
gpt show: /dev/disk0: Suspicious MBR at sector 0
      start       size  index  contents
          0          1         MBR
          1          1         Pri GPT header
          2         32         Pri GPT table
         34          6         
         40     409600      1  GPT part - "EFI System Partition"
     409640  897300848      2  GPT part - "Customer"
  897710488    1269536      3  GPT part - "Recovery HD"
  898980024       1864         
  898981888   78123008      4  GPT part - "BOOTCAMP"
  977104896        131         
  977105027         32         Sec GPT table
  977105059          1         Sec GPT header
[22:57:28]~$ sudo fdisk /dev/disk0
Disk: /dev/disk0    geometry: 60821/255/63 [977105060 sectors]
Signature: 0xAA55
         Starting       Ending
 #: id  cyl  hd sec -  cyl  hd sec [     start -       size]
 1: EE 1023 254  63 - 1023 254  63 [         1 -     409639] <Unknown ID>
 2: AC 1023 254  63 - 1023 254  63 [    409640 -  897300848] <Unknown ID>
 3: AB 1023 254  63 - 1023 254  63 [ 897710488 -    1269536] Darwin Boot 
*4: 07 1023 254  63 - 1023 254  63 [ 898981888 -   78123008] HPFS/QNX/AUX
  • Possibly Windows has not assigned a drive letter to that partition. See here on how to assign one. Commented Jan 18, 2015 at 14:22
  • @Vic, this option is disabled for the partition.
    – klm123
    Commented Jan 18, 2015 at 18:12

3 Answers 3


I need some more information before I can answer your question. First, what model is your mac?

Second, please run the following commands from the OS X Terminal app. Please post the results for me to read.

sudo diskutil list
sudo disktuil cs list
sudo gpt -r -vvv show -l /dev/disk0
sudo fdisk /dev/disk0

All these commands do is list information about your disk. They do not change anything. The commands may ask for your login password. This is normal.

I am trying to determine if you are using coreStorage. If not, then the problem might be the age of you computer. The drivers for windows 7 may not be compatible with OS X 10.10.

See this Apple Support Communities post: windows 8 does not recognise Macintosh HD, No drive Letter.

Just a note about the article you reference:

The article is full of problems and errors. While it is true the default partition names are "Macintosh HD" and "BOOTCAMP", often users change these volume names. The author should have known this. Also, if you follow the instructions in the section titled "Create a Shared FAT32 Partition", your computer will not be able to boot to windows. The reason for this is simple: Windows can only see the first 4 partitions on your disk. The first partition is the EFI partition. It is normally hidden when viewed in the Disk Utility. The second partition is the HFS+ OS X boot partition. The third is the recovery partition which is hidden also. The Fourth is used as the Windows Bootcamp partition. If you try to insert a FAT32 partition, the Bootcamp partition would become the fifth partitioned, thus preventing windows from booting.


Well, you are using Core Storage which is probably the problem. Windows does not recognize partitions using Core Storage. My understanding is that Yosemite converted your OS X partition from HFS+ to Core Storage. You need to change it back to HFS+. klanomath at Can't make more than two partitions seems to have the answer. Here he has solved a different problem, but his solution steps should work for your problem as well. I would follow his steps with some minor changes. I have listed them below.

For his step 1, I would just use the recovery partition already on your disk. In other words, press the alt key while booting and select the recovery partition to boot to.

For his step 3, the command would be:

diskutil cs revert 4BB22737-5EFB-49D6-ADF1-5B719538AF45

Omit step 5.

Also, I would use the Disk Utility to backup the partition before entering the above command. This would require an external disk to store the image on, which you may not have. If you wish to do this and do not know how, let me know.

Let me know how things turn out and don't forget to give klanomath some reps.


  • I added the info.
    – klm123
    Commented Jan 18, 2015 at 22:01
  • So you're saying I can't trust this: "Yosemite logical volumes cannot be read on Windows bootcamp anymore since they are not HFS+ volumes but they are now CoreStorage." ?
    – klm123
    Commented Jan 18, 2015 at 22:02
  • @klm123: klanomath seems to have a better solution than I would have come up with. Please read my updated answer. Commented Jan 18, 2015 at 23:12
  • I looked into this. Even though I wanted to have 3 partitions and it was an issue with new OSX as well, I think the result doesn't not worth the danger of losing information and making my OSX installation not standard. At least for today. But I think your answer is fully answers my question and I accept it.
    – klm123
    Commented Jan 19, 2015 at 15:31
  • To be clear to you and other readers, klanomath's solution (if successful) would have given windows access to your OS X partition. As for partitioning in general, it is possible to have more than two visible partitions and run windows on a Mac. For example, my Mac has 2 NTFS partitions, 1 ExFAT partition and 2 HFS+ partitions and I am not using Core Storage. Windows is version 8.1 64bit and OS X is 10.10.1. Granted the install is not standard, do to the fact, I had to install the Windows partitions before the OS X partitions. Commented Jan 19, 2015 at 18:18

Your data in Mac drive may be encrypted by FileVault, so other OS suppose not to see this encrypted drive. Go to System Preferences -> Security and Privacy -> FileVault -> Turn off. It works based on my experience.


Thanks so much to David Anderson for the response to this article- Got me looking in the right direction.

There's a little simpler article and method I found over here, I didn't need to reboot into recovery to make it work. Mac Partition shows up perfectly, now.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .