0

I've got a Macbook Pro Retina (with the PCIe drive ‘blade’, instead of a traditional 2.5" laptop drive). I've recently upgraded the internal drive from 500GB to 1TB, and dd'd the old drive over the new one to retain my partition setup and Bootcamp partition.

Unfortunately, this didn't go well: for whatever reason, OS X wouldn't recognize, once I'd booted up on the new 1TB drive, that there was 500GB of new space available. It was showing up in Disk Utility as greyed-out space.

To aid in debugging this, I wiped out the Bootcamp partition entirely (I have backups. I intend to restore that later, once I've got the drive fixed up from within OS X.); and eventually, after getting fed up trying to get diskutil cs resizeStack to work, I diskutil cs revert'ed the boot volume entirely.


Now I have this situation:

> diskutil list
/dev/disk0
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *1.0 TB     disk0
   1:                        EFI EFI                     209.7 MB   disk0s1
   2:                  Apple_HFS Fannie's HD             499.4 GB   disk0s2
   3:                 Apple_Boot Recovery HD             650.0 MB   disk0s3
> diskutil cs list
No CoreStorage logical volume groups found
> diskutil resizeVolume disk0s2 limits
For device disk0s2 Fannie's HD:
        Current size:  499.4 GB (499418034176 Bytes)
        Minimum size:  330.0 GB (329959456768 Bytes)
        Maximum size:  499.4 GB (499418034176 Bytes)

After trying to drag the single partition in Disk Utility from 500GB up to 1TB, and then clicking ‘apply’, the process appears to proceed, and complete; but as soon as the completion message appears in the bottom-right, the partition map reverts to what you see in the screenshot. It never succeeds in re-sizing to 1TB. (Here's the verbose log, along with some other details obtained from the command-line.)

(Attempting to do the same from the recovery partition's Disk Utility gives an ‘Error: could not unmount disk.)

At this point, all I want in the world, is to re-size the single partition on my drive from 500GB to fill the available 1TB of space. Once I succeed with this, I'll be able to convert it to a CoreStorage volume, encrypt it, partition for Bootcamp and such.

Please help!

Edit: Other posts I've read through: Christian's, and Chrisii's summary of undocumented CoreStorage commands

1

I recommend you

  1. backup your data before you running the command below
  2. Repair disk via Disk Utility App in Recovery Mode if needed

and then run this command in terminal

diskutil resizeVolume disk0s2 0b

  • This worked! I have no idea why, after all the things I tried, but it worked! Thank you so much, guys. – ELLIOTTCABLE Apr 19 '15 at 21:46

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .