1

I'm running OS X Yosemite 10.10.1 on my Late-2013 MacBook Pro. A couple of days ago my Safari (8.0.2) started behaving a little weird when searching. This became really annoying and I have no idea how to fix it.

Whenever I search using my address bar and confirm it by pressing Enter, the bookmarks list opens on top of my search result. I then have to click somewhere in order to close the list. This only happens when searching, not when typing any url's in there.

I don't think this could be a desired behavior for anyone and I have looked at my preferences, but couldn't find any settings related to it.

I hope you can help me to disable it.

  • I have the exact same issue, and would be extremely surprised if it were expected behaviour. Is there any solution to this? – user119322 Mar 23 '15 at 22:24
1

Under Safari Preferences -> Search -> Smart Search Field -> uncheck the "Show Favorites" option

enter image description here

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .