4

In order to use handoff/continuity at work I need to connect my Mac and iPad/iPhone to the same wifi network. Moreover, I also need to be connected to the separate office ethernet LAN to get my job done.

We keep the networks separate for security purposes. I don't want to make my mac the way the wifi network can be used to gain access to the internal ethernet network.

It works when I'm connected to both. But all my Mac's remote services are exposed on the wifi network. No good docs on advanced firewall config. I have no idea how the built-in firewalling interacts with PF. I prefer to avoid digging in the depths of PF.

Can this be done securely without massive headache?

1 Answer 1

5

This is quite easy.

  • Open settings app
  • select wireless networking
  • remove the password for any/all networks you don't want to join and
  • turn off / disconnect from Wi-Fi
  • wait a dozen seconds
  • Turn on Wi-Fi and validate no network is joined

The Wireless radio will be on and ready for handoff or AirDrop but not joined to any network/SSID. The computer will work fine with wired ethernet and a Wi-Fi radio on but not associated with any network that's in range.

7
  • Nifty! No idea it would work without a network association. I'll give it a whirl when I get back into the office. I'll report back then! Commented Jan 17, 2015 at 14:40
  • @user2458080 It's really solid. The Bluetooth and WiFi both operate in ad-hoc mode - you can tail the /var/log/system.log to watch it build up a mesh network and see the handoff notifications arrive. The only gotcha would be if you use iCloud keychain and another device joins that network. You would then need do disable iCloud keychain on one or the other to prevent an inadvertent join later of the Mac to the SSID.
    – bmike
    Commented Jan 17, 2015 at 14:53
  • So, in my 5 minutes of testing this morning, I got handoff to work with web browsing and iMessage. I was not able to get it to work with handoff calls. My iPhone is on the external wifi and my mac has wifi on, but it is not associated with any wifi network. Commented Jan 20, 2015 at 13:48
  • oh, and that keychain thing sounds scary. One of the nice things about iCloud is the keychain secure credential sync'ing. Having to turn that off is disappointing. I guess you can't have your cake and eat it too. Commented Jan 20, 2015 at 14:13
  • 1
    I do appreciate your answer that gets me 50% there. I'm still holding out for an answer that can handle handoff calls and a solution that works without having to disable keychain. Commented Jan 21, 2015 at 13:49

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .