I want to create a BootCamp partition on my 13" MBP with a 250 Gb hard drive.

The DiskUtility shows the partition as Mac OS Extended (Journaled). Mac OS Extended (Journaled).

When trying to perform a partitioning with BootCamp Assistant, after the progress bar gets to about 40% of partitioning, I get the alert stating:

The disk cannot be partitioned because some files cannot be moved.
Back up the disk and use Disk Utility to format it as a single Mac OS Extended (Journaled) volume. Restore your information to the disk and try using Boot Camp Assistant again.

Here's what it looks like: partitioning problem

Now this gets me confused - what I really should do and what's the core reason of the problem?

  • 1
    boot up using the Mac OS X install DVD and try repairing the disk. the same error happened to me and doing that fixed it.
    – user6124
    Commented Jun 30, 2011 at 10:23

2 Answers 2


Yep, that's kinda odd. Might be because it needs to partition a contiguous chunk, for efficiency reasons, for Windows. If that's the case, and it's got some immoveable files within that contiguous chunk, I could see it having issues.

I wonder if it would be possible to run boot camp assistant from the OS X disk instead. If you can, those files could probably be shifted as you wouldn't be booted from the 1st partition anymore.

Alternately you could create a bootable partition on an external hard-drive and do the same from a fully functioning OS X installation. Finally, the last resort would be to use a 3rd party utility to add that NTFS Bootcamp partition. I don't recommend that route.

  • My snow leopard boot disk doesn't seem to have a BootCamp Assistant app while I boot from it - it has a DiskUtility though, which I'm giving a try now...
    – kender
    Commented Jun 30, 2011 at 8:21
  • @kender - Aah crap. Okay. Let me know how you make out, I'll help you if I possibly can.
    – Harv
    Commented Jun 30, 2011 at 22:31

Harv's right in that this means there isn't a big enough contiguous chunk to partition. The easiest (but perhaps most time consuming) remedy that I know of would be:

  1. Back up using Time Machine.
  2. Boot to the OS installer, repartition the drive as a single partition (ignore the instinct to partition the drive for Windows now - let Boot Camp assistant take care of that later).
  3. Reinstall the OS.
  4. Choose to restore from a Time Machine backup during the Setup Assistant.
  5. Once this is done, run Boot Camp assistant, and then it should have no issues.

This has worked for me every time I've needed to do it. It might be possible to use SuperDuper! or Carbon Copy Cloner to back up the drive and just restore that image/clone the drive back over, but I don't have firsthand experience doing it that way.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .