8

I don't seem to be able to synchronize my iPad (2) and IPhone (5s) to access the iBooks documents saved across the devices. They are both updated to the latest iOS. I Have looked into all the settings and they all appear to be OK, but still don't know if I am missing to set the the ones that engages the iBooks. I noted that in the iCloud "settings" I don't see the iBooks icon as I do with the Photos, Mail, Notes, contacts, Calendar, etc., which I manage to see across devices.

However, I don't find a way for iBooks to add it or for making it into my iCloud Settings screen menu.

Can I kickstart a sync to get iCloud working for iBooks?

  • what do you want to do? do you need sync (download) the punched book from your Mac to iPad and iPhone ? – nelson Jan 16 '15 at 15:46
  • 2
    Rather than saying you looked into all the settings perhaps list the exact sequence to get to the settings you are checking or provide a screen shot of one of the devices with the applicable settings. – bmike Jan 16 '15 at 16:09
  • Nelson: I don't have a Mac. I am trying to find the way to sync my iPhone and iPad iBooks to see my Docs in there, particularly PDF files. Tks. – Luis G. Jan 18 '15 at 4:21
  • Bmike: I will review the settings of interest to make the screen shots to see how I can get the help to resolve the sync issue with iBooks to access my PDFs betweend the two devices. Tks. – Luis G. Jan 18 '15 at 4:25
  • While looking at the settings menu to take screen shots, I noted that iBooks is not listed in the Apps included in my iCloud settings menu. If that is the issue, how I can add iBooks to the iCloud App menu? I tried adding the screen shot in this comment using my iPad to no avail. Tks for the help. – Luis G. Jan 18 '15 at 15:24
2
  • Open Settings app on both devices and verify both have an iCloud backup (or connect to iTunes and back up both)
  • Sign out of iTunes & App Store and then reboot both devices
  • Sign back in to the iTunes & App store on one device
  • Open iBooks and see what it shows for your purchases / books.
  • Tap to download one of each (a purchased book and a synced book)
  • Then review the iBooks settings in the settings app for this device

Repeat the sign in steps for the second iOS device. Pay attention to the "Sync Collections" setting for iBooks.

|improve this answer|||||
  • Sign out & Rebooting and sign in the two devices did not work. – Luis G. Jan 18 '15 at 4:28
1

I've encountered this a couple of times and the following always gets things working again for me.

  1. Open System Preferences, click Apple ID
  2. From the list of "Apps on this Mac using iCloud", select "Options" for iCloud Drive
  3. Uncheck Books, then click Done
  4. Repeat steps 2 and 3, but this time check Books again

My iBooks library synced immediately after this. I'm running MacOS Catalina.

|improve this answer|||||
0

So I had the same problem but I figured it out. I backup my iPhone like he said.

  • Then I clicked on my iPhone icon on my iTune.

  • Click the first book icon and select Sync Books. you have the option of syncing all your books or selected books. Select the Sync button below and apply.

  • Once this is done click on the second books icon to see your books. Note if your books are not completely sync they won't appear on this section.

  • Then go to your iPhone, open your iBook and click the books icon.

  • If it still didn't work, delete your iBook app and download it again.

  • Click on OK to allow books to sync.

|improve this answer|||||

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .