2

I have this problem that's been bothering me for a few weeks now. In my Apple Mail on MacBook Pro I have 4 Mailboxes. One of them is Gmail synced via IMAP.

When I open the app everything works fine for about an hour, then an exclamation point next to my Gmail inbox appears saying "Too many simultaneous connections". This is nonsense because this is the only app accessing the e-mail. I know its creating more connections in background but...

The problem is that after this hour elapses, the whole Mail app is kind of frozen. Sending e-mails stops at 80% and won't finish (even all other mailboxes) and the app doesn't synchronize all the mailboxes at all. From time to time the whole app crashes completely.

Any ideas what could be wrong and Where to look for more details about this? Anyone with similar problems? Thank you!

3

check this link - gmail changed their authentication method without notice, so you have to make this change. You will get a confirmation email from gmail that seems scary - but it isn't. You haven't just opened your email to the world as they try to scare you to believe. Unfortunately, as usual, they don't work in concert with major software developers and we are left to pick-up the pieces as best we can.

https://productforums.google.com/forum/#!topic/gmail/lCjm9oim5Vo

  • Welcome to Ask Different! While this link may answer the question, it is better to include the essential parts of the answer here and provide the link for reference. Link-only answers can become invalid if the linked page changes. – grg Feb 11 '15 at 20:21
1

It's hard to say what the problem might be. But the first thing I would try is to delete the account from Mail and then create it again. Since it's all IMAP anyway, you won't lose anything except the local copies. When it is recreated, it will have to download everything again but it should at least be a clean copy. If you are still having crashes after that... well, then it could be many many things. But one thing at a time and that's the first thing I would try.

1

Turn off contact syncing for the Google account and add your Google contacts sync back via CardDAV:

  • Go to System Preferences > Internet Accounts
  • Uncheck "Contacts" for the Google account
  • Click the "+" to add a new account
  • Select "CardDAV"
  • Set Account Type to "Manual"
  • User Name is Gmail address
    • Password is the Gmail address password, or a new app-specific password if 2-factor authorization is "ON" for Google Server
  • Address is "google.com"
  • Now enjoy your responsive Contacts app.

I had to turn on “Allowing less secure apps to access your account” in Google options. (Otherwise impossible to create an CardDAV account.)

0

Thank you all for answers. I have done some research on the subject and it seems this is a common problem in Mac community unsolved for years. Apple reacted on this about a year ago with the message like "Our team is working on it". The Mail app is trying to parallelize syncing (I believe) and it causes more connections than allowed by Google.

The final solution that worked for me is to wipe out your Mail app completely via deleting all the application data and then set it up again from ground up. If you have IMAP accounts you wont lose any e-mail. Be sure to back up your e-mail signatures, filters and double check you have all the settings you need to set up all your e-mail accounts again. E-mail app now works like charm without any problems.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .