3

The Yosemite upgrade completely hosed Mail—it just won't talk to the Exchange server anymore.

"No problem," I think, "I'll just delete the account and start over as it's all on the server."

If I try and delete the account from Mail.app's preferences, it says "The Mail account “foo@bar.com” is shared by other applications on this Mac. You can remove this account in Internet Accounts."

Ok, so I click on Internet Accounts, it opens Preferences, and the Exchange account isn't there.

(Interestingly enough, I get the exact same problem when I try and remove the account via Contacts and Calendar's preferences—even when "Enable this account" is unchecked in all three.)

So how do I force Yosemite to delete all traces of an Exchange account?

  • a bit late for you right now, but Yosemite introduced a new 'auto-update' settings which needs switching off. – Tetsujin Jan 16 '15 at 9:07
  • I'd delete an Exchange account and then later it would 'reappear'. Extreme, but what I ended up doing was greping for the mail server of the account I wanted to remove (from /!) and then removing the entries via the command line. – eebbesen May 25 '15 at 18:58
4

The thing is since MountainLion with cached preferences. You could try the following really hard solution (last line of defense), which trashes all you Apple Mail settings and all of your Internet accounts including twitter accounts etc. et al:

  • backup your Library folder to somewhere else like your Desktop or another HD
  • from Terminal, delete the folder "~/Library/Containers/com.apple.mail" and "~/Library/Containers/com.apple.internetaccounts"
  • from Terminal, delete Apple Mail Preferences with "defaults delete -app Mail" (this resets your apple mail plist to default values)
  • logout and login again.

If this doesn't work, copy your Library folder back and we have to find another way.

  • This helped me get to the point where it seems like autodiscover.mydomain.com's DNS record is borked and not pointing to where it should be, but that's not Yosemite's fault. Thanks! – Robert Atkins Jan 30 '15 at 11:13
  • Strangely, after doing these three steps -- removing the two directories and doing the default delete... the accounts are all still there. Any ideas? – Dan Rosenstark Aug 21 '15 at 14:46
4
  1. Close Mail.app
  2. Go to ~/Library/Mail/V2
  3. Remove the complete folder of the account you'd like to get rid of.
  4. Go to ~/Library/Mail/V2/MailData
  5. Oben file Accounts.plist
  6. Find two sections defined with <dict>…</dict> containing the name of the account and delete them.
  7. Close the file, start Mail.app

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .