1

Firefox has a problem by which you can't assign it a shortcut to zoom the window.
As it has another menu item named "Zoom" which actually has subitems for zoom in, etc. you can't map the shortcut by menu item name, because that item takes the stroke instead of the window zoom.
I tried to edit Firefox's resources, to see if there was a .nib where I could rename the menu item to another thing so the shortcut would find the correct "zoom" item, but failed.
Does someone have a solution for this?

edit: I'm talking about MacOS's Zoom Window action equivalent to Windows' Maximize, and not about zooming the contents in or out.

  • What do you mean by 'zoom' (increase the size of the window or the same as control scroll? – Digitalchild Jun 30 '11 at 4:24
  • Yes, Zoom as making the window fit the screen, as in Window's Maximize. – Petruza Jun 30 '11 at 13:25
2

Firefox uses XUL files to define its user interface on all platforms. I just did a little poking in my Firefox.app 4.0.1 bundle:

  • The XUL files are stored in Firefox.app/Contents/MacOS/omni.jar. (jar files can be unpacked with any Zip archive tool, or the jar command-line tool which takes options like tar.)
  • The relevant XUL file may be chrome/browser/content/browser/baseMenuOverlay.xul. See also the referenced DTD files for the definitions of the entities like &zoomWindow.label;.

Since you're editing the files anyway, you might as well add a shortcut there rather than changing the name to use the system shortcut customizer.

1

Apple - Shift - F will do the trick, I believe.

  • nope, but thanks anyway – Petruza Jul 12 '11 at 19:07
  • That's fullscreen. – Petruza Dec 11 '11 at 16:32
1

Go to System Preferences > Keyboard > Keyboard Shortcuts > Application Shortcuts and add one for Firefox. Get the name of the menu item for, say, Zoom In and assign it a shortcut, then repeat for Zoom Out.

It sounds like you're saying there is some reason you can't do this, but if you tell it "Zoom In" (or whatever it's called; I haven't installed Firefox on this computer yet) rather than "Zoom" I don't see why it wouldn't work.

  • 1
    Thanks for the answer but I have since switched to Chrome, which surprisingly enough conforms to its operating system usability guidelines ;). – Petruza Jan 16 '12 at 21:30
  • 1
    But answers could help someone else with the same problem, so even if the original poster doesn't need more suggestions, others may. – Daniel Jan 16 '12 at 21:36

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .