4

I've been using Yosemite happily since it was released, but yesterday all my icons disappeared. See the attached screenshots. My dock only shows the icon for the Finder, and within Finder itself none of the icons for applications or folders show up. The only thing that seems to work is thumbnail previews for things like Word documents, PDFs and image files.

enter image description here enter image description here

These are some things I tried already:

  • rm -rf ~/Library/Caches/* and sudo rm -rf /Library/Caches/*
  • rm ~/Library/Application\ Support/Dock/*.db && killall -HUP Finder Dock
  • rm ~/Library/Preferences/com.apple.finder.plist
  • I tried booting in Safe Mode, the problem persists there.
  • I even tried reinstalling the OS and for some reason the problem still exists.
  • Unfortunately I can't log in as a different user, this is a company mac and my login is our network login.

I'm at a total loss. What can I do? The only thing I can think of that I changed recently was uninstalling an app called Bitcasa by manually removing some of its application files, including /Applications/Bitcasa.app, ~/Library/Preferences/com.bitcasa, ~/Library/LaunchAgents/com.bitcasa.Bitcasa.plist, ~/Library/ScriptingAdditions/BitcasaIntegration.osax, ~/Library/Caches/com.bitcasa.Bitcasa, and ~/Library/Application Support/com.bitcasa.Bitcasa.

  • If after reinstalling the OS the problem persist, then it is usually your preferences settings, since those do not get changed when reinstalling. – Ruskes Jan 15 '15 at 17:28
  • Is there a way to reset preferences to default? – bhamrick Jan 15 '15 at 18:01
  • for what is worth, run disk permission repair for now. and try to log in as different user to check that. – Ruskes Jan 15 '15 at 18:09
  • I just checked the instructions for Bitcasa removal here support.bitcasa.com/hc/en-us/articles/… and assume you did to? – Ruskes Jan 15 '15 at 18:16
  • Unfortunately I can't log in as a different user, this is a company mac and my login is our network login. – bhamrick Jan 15 '15 at 22:36
1

I was having a similar problem--not with icons in the dock--but Illustrator icons in Finder list view would just display as blank white icons instead of the Illustrator CC icons. Using the info in this thread, I showed all hidden files. This can be done using the XtraFinder app. Once all hidden files were shown, I went to the path below and moved the store.index file to the desktop and logged out and logged back in. The store.index file re-created itself and all of my Illustrator icons were back. You can delete the one on the desktop and empty the trash before once again hiding all the hidden files through XtraFinder. Solved!

HD/private/var/folders/*/*/C/com.apple.iconservices/store.index

The asterisks represent random folder names that are different for each computer. The last asterisk may have more than one folder. Find the C folder that is not locked.

  • Your solution has resolved my problem. Thank you :). – Huynh Inc Jul 12 '15 at 10:14
-1

The icon caches in OS X are stored under /private/var/folders. To clear them try the following commands in a Terminal window.

sudo rm /private/var/folders/*/*/C/com.apple.dock.iconcache
sudo rm -rf /private/var/folders/*/*/C/com.apple.iconservices
killall Dock
killall Finder

Hopefully you should then find your icons restored.

  • 2
    It's unadvisable to remove the folders for all users (including root and other system files) in that manner. – Kent Jan 15 '15 at 22:25
  • What would you recommend instead? I know one person's anecdotal evidence isn't worth much, but I've done this a few times over the years without any ill effects. The system seems to quite happily regenerate the files/folders as it needs them. – Alistair McMillan Jan 15 '15 at 22:29
  • 1
    Interesting, but I assume you are aware that the 'C' in the paths above signifies "Cache". The folder actually used to be called "-Caches-" in previous versions. Surely something very strange would have to happen for anything irreplaceable to end up in one of these folders? – Alistair McMillan Jan 15 '15 at 23:02
  • 1
    Yes -- I actually missed that the first time. My head gets queasy whenever I see "sudo", "rm" and "*" on the same line anywhere. :-) – Kent Jan 15 '15 at 23:24
  • 1
    I know that feeling. I'm normally the one advising caution. Telling people to never delete thing; just rename them. – Alistair McMillan Jan 16 '15 at 0:35
-2

What worked for me (on 10.10.5) what to logout, login as a different user, and then log back in as me.

  • 1
    The OP has stated that he/she cannot log into a different user account and has already tried rebooting the computer. – Matthew N Feb 5 '18 at 22:13

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .