0

I have a basic PPTP VPN connection set up, but when I connect to it, my Mac immediately looses internet connection. Skype still routes and works, but internet connection dies.

I don't have "Send all traffic over VPN connection" enabled. Even it is enabled, the internet connection is still dead.

I have the following custom routing setup in /etc/ppp/ip-up:

#!/bin/sh
/sbin/route add -net 192.168.1.52 -interface ppp0

Any advice please?

3

I have the exactly same issue on both Wi-fi and Ethernet connections. It started after upgrading from Maverick to Yosemite and all my VPN connection were behaving the same.

I got in touch with Apple support regarding this problem and their procedure was as follows:

  1. Create a new network location (which gives us fresh network settings to work with)
  2. Create the VPN connection in this new location
  3. Test

If the problem persists (my situation) then your old settings are not the problem.

  1. Create a new user (administrator rights)
  2. Log in with this new user
  3. Test again

If your problem persists (my situation) then your user settings are not the problem.

At this stage they said the problem should be the VPN providers, but in my situation nothing was changed from their end and I am using their services for more than a year now.

Continuing my research I suspected the problem should be DNS related. I can ping external addresses by IP, but not by DNS, and my local network still works.

As a temporary solution I entered my router's address in the VPN DNS Servers.

  • Thanks so much! Creating a new network location solved this issue for me. Also setting the service order so that VPN is below Ethernet and Wifi. – Anriëtte Myburgh Jan 26 '15 at 7:59
  • Same problem here. After VPN connect, I loss the netowrk access, so I can not be able to connect with RDP (to local and remote pc as well). I probe several offered solutions, but only one of them solved the compliant: create new location, and in that new location I create new VPN and everything are fine. Thank you very much Gabriel Fernandes Montei. – user121231 Apr 8 '15 at 20:51
  • Setting the location worked! I have been dealing with this issue for a few weeks. I have no idea why it works, but it really is great to now have my connected devices go through the VPN where necessary and still have access to the Internet. – Gandalf458 Apr 1 '16 at 16:47
0

I found:

On the WI-Fi DNS settings there was only my routers IP address - 192.168.0.1.

I have looked at the settings on another MAC and I had:

62.6.40.162

194.74.65.69

I added them to the DNS list. Don't know if I'm doing anything wrong but it does appear to have fixed it.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .