4

So, I have run into a bug where iMessage syncs my normal SMS-messages with Messages on OS X.

The problem is that the message doesn't want to get read. I click on the sender (automatic SMS from a computer notifying me of an email), the (1) disappears for a second and then returns.

The message does NOT show up unread on my iPhone or iPad,

I've tried the following: - Restarted Messages - Closed the conversation - Deleted the conversation

But no luck.

I'm going to restart my computer now, but in the meantime I hope you can come with a solution. Maybe something like "Mark all as read"?

enter image description here

6

This problem is fixed in a new release of 10.10.2

I'm currently running 10.10.3 and am having this issue again, so not fixed in 10.10.2 unfortunately. Have experienced in the past, major pain.

The following works for me every time

In the Finder > Go Menu > Go to Folder type (Copy and Paste) ~/Library/Preferences into the Dialogue box.In the Preferences find the com.apple.imessages.bag.plist and drag it to the Trash.

(found on https://discussions.apple.com/thread/4486753?start=0&tstart=0)

Then reboot the machine. The post says to reboot messages but I always have to reboot the entire computer for this to work properly.

2
  • This worked for me after rebooting.
    – frhd
    Oct 18 '15 at 16:02
  • 1
    Removing that file worked for me too. I ran killall Dock from the terminal to reset the indicator without requiring a reboot. May 23 '16 at 16:02
2

I had this problem too. I disconnected all accounts in messenger, disabled handover, rebooted, and added accounts again + enabled handover. This solved the problem.

This problem is fixed in a new release of 10.10.2

3
  • Although restarting my computer worked (for now), I'll remember this for the next time if restarting doesn't help anymore.
    – Rvervuurt
    Jan 15 '15 at 9:23
  • No, it was not fixed in 10.10.2, I have same problem too on 10.10.2. SMS message is often marked as unread even I read it.
    – user121290
    Apr 9 '15 at 9:04
  • Still getting this problem in 10.11.5, so definitely not fixed. Or a regression. Jun 28 '16 at 13:15
2

I right clicked on the icon and it showed what message was unread. I clicked on Digital Post (1 unread) and it took me to the message but the red dot was still there. So I replied to the message and the red dot disappeared. Not sure if that works for everyone but it worked for me this time!

1
  • Excellent. This is a very simple way to find the unread messages! Thank you for your answer.
    – ephsmith
    May 15 '19 at 21:16

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .