4

I'm using Gmail on my iPhone 6 (IOS 9.1). When I archive some messages (by swiping left on the message in the Mail.app), they disappear from my Inbox, then get added right back a second or two later. This has been going on since IOS 8.1 and still isn't working right since upgrading to IOS 9.1 I figured it would have been fixed, but it's not.

I tried archiving to different folder than All Mail but that didn't solve the problem. Also, there is no pattern to the messages. This is happening regardless of who the message is from or its content.

I gave up after a year of dealing with this annoyance and using Outlook for now, but I'd really like to use the Mail App on my iPhone again.

Does anyone know how to fix this?

One other possibly related and interesting note, the mail app in OS X also does the same thing (click the archive button, message disappears for a few moments then pops back in the inbox, then disappears again). Perhaps IMAP commands are being queued up, then mail refreshes and notices the message hasn't been actually moved yet, and adds it back to inbox... just my theory.

6
  • how do you archive? be aware that gmail uses something called "all mail" that is called archived mail on Mac.
    – Ruskes
    Jan 14, 2015 at 16:56
  • Edited question to explain how I'm archiving. Jan 14, 2015 at 19:21
  • Thank you! see this support.apple.com/en-us/HT202067
    – Ruskes
    Jan 14, 2015 at 19:28
  • Thanks for the link. Yes, this is how I'm archiving my messages (question updated again with link). However, when the message is archived it disappears for a few seconds and it added right back to the Inbox. It only happens to some messages. Jan 14, 2015 at 19:34
  • so what is so special with those messages?
    – Ruskes
    Jan 14, 2015 at 19:38

1 Answer 1

1

This could be an issue with your iPhone settings.

Go to settings > mail, contact, calendar > Gmail

Here you will see you gmail account, select it. On the following view, there is an option for advanced settings.

Here you can change to with folder archived mails should be placed.

Please let me know if this solved your problem.

5
  • Thanks for your answer. I verified that the Archived messages will go to All Mail. Jan 14, 2015 at 19:50
  • And when you change that folder, do they still appear on your inbox than?
    – Jules
    Jan 14, 2015 at 19:51
  • 1
    Jules, are you suggesting that I change the Archive folder from All Mail to something different, to see if that solves my problem? Won't that create a new problem for me (mail is being moved to some other folder, and not the All Mail folder)? Jan 14, 2015 at 20:40
  • when you select another folder, your archived gmail mails will be placed there. I suggest you change the folder to see if it solves your current problem
    – Jules
    Jan 14, 2015 at 20:42
  • 2
    The setting should be set to All Mail. I have tried changing it, but the behavior persists. Would love to know if anyone has a solution, but I am guessing this is a known incompatibility.
    – Phoebe
    Apr 13, 2015 at 20:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .