On two separate MacBook Pros (one brand new, one several years old) running OSX Yosemite, all bluetooth audio devices are choppy (audio clicks in and out, skips like a scratched CD).

I have tried playing audio through Spotify, iTunes, YouTube with Beats Studio wireless headphones and a Big Jambox on both, in separate environments. Sometimes the sound is perfect and clear. Then it suddenly becomes choppy.

I've looked at Activity Monitor during choppy times, and nothing seems different from normal.

For the record, using the same Wifi and devices, iOS8 iPhone 6 and 5S both do not have this issue.

I'm curious how to even begin to troubleshoot the issue - It's hard to troubleshoot as there's no way of knowing if it's interference, app performance, etc.

  • 3
    My experience with Yosemite from day one has indicated serious wifi/bluetooth issues. This is backed up by thousands of other mac users experiencing a wide variety of issues most likely related to bluetooth/wifi. I'm hoping it will be resolved in 10.10.2 but unfortunately I reckon you might be out of luck until then...! Out of curiosity are you using 2.4GHz wifi at the same time? If so, try with ethernet or 5Ghz and see if you get better results
    – doovers
    Commented Jan 14, 2015 at 1:19
  • @doovers Thank you - That's a great suggestion. I've turned off WiFi on this machine, but with no luck. Though, it sounds like it may be less choppy as things were previously - hard to tell since the choppiness happens so intermittently
    – venables
    Commented Jan 14, 2015 at 15:42
  • I am experiencing similar problems. Crackling sound and sometimes audio stops suddenly and just high volume noise remains. I need to reconnect device. I tried with Bose SoundLink Mini and JBL with same results. Problem is somehow connected with switching graphics desktops on my LG monitor if I don't do any switching and put all apps on one desktop it never happens. Maybe some bug with Thunderbolt connection of LG monitor. Monitor suffer some issues from time to time as well.
    – user112247
    Commented Feb 3, 2015 at 10:00
  • Try disconnecting your bluetooth keyboard.
    – Arne
    Commented Sep 4, 2017 at 19:00

3 Answers 3


It's an issue with the amount of power/bandwidth supplied to the BluetoothAudioAgent, the daemon in charge of streaming. Apparently most people have had success by entering the following command in terminal.app:

defaults write com.apple.BluetoothAudioAgent "Apple Bitpool Min (editable)" -int 40

Source: http://lifehacker.com/fix-your-bluetooth-audio-in-yosemite-with-this-terminal-1670380974

The source article lists Yosemite as the specific OS this applies to, but I know that this fix also works back to Mavericks and (possibly) Snow Leopard (untested).

I am having this exact issue at the moment and entered that command with non-noticeable results. I'm going to reboot the machine and see if that takes the new settings into account. But it seems like this command is the way that the wide majority of people have resolved this issue.

EDIT: Just rebooted, the audio quality is significantly better. No noticeable choppiness whatsoever (knock on wood). It appears that the command I posted above does seem to resolve the issue.

EDIT 2 (2015-8-24): The above command does help in many cases and produces noticeable quality improvements. Unfortunately, however, Yosemite is very moody with regard to bluetooth audio. The problem compounds itself when in proximity of other bluetooth devices. To expand on my previous answer above, I highly recommend entering the following additional commands to increase other bluetooth audio parameters:

defaults write com.apple.BluetoothAudioAgent "Apple Bitpool Max (editable)" 80 
defaults write com.apple.BluetoothAudioAgent "Apple Bitpool Min (editable)" 48 
defaults write com.apple.BluetoothAudioAgent "Apple Initial Bitpool (editable)" 40 
defaults write com.apple.BluetoothAudioAgent "Apple Initial Bitpool Min (editable)" 40 
defaults write com.apple.BluetoothAudioAgent "Negotiated Bitpool" 58 
defaults write com.apple.BluetoothAudioAgent "Negotiated Bitpool Max" 58 
defaults write com.apple.BluetoothAudioAgent "Negotiated Bitpool Min" 48

EDIT 3 (2015-9-08): Alright. I'm sorry I keep updating this answer, but I keep finding more information about this issue (since improving bluetooth audio on Yosemite is a long-term effort, apparently). I've found several sources that cut straight to the mustard and set everything to 80 which appears to be the maximum allowable value for Bitpool settings. If the above settings don't work well enough for you, try the "All In™" approach.

defaults write com.apple.BluetoothAudioAgent "Apple Bitpool Max (editable)" 80 
defaults write com.apple.BluetoothAudioAgent "Apple Bitpool Min (editable)" 80 
defaults write com.apple.BluetoothAudioAgent "Apple Initial Bitpool (editable)" 80 
defaults write com.apple.BluetoothAudioAgent "Apple Initial Bitpool Min (editable)" 80 
defaults write com.apple.BluetoothAudioAgent "Negotiated Bitpool" 80 
defaults write com.apple.BluetoothAudioAgent "Negotiated Bitpool Max" 80 
defaults write com.apple.BluetoothAudioAgent "Negotiated Bitpool Min" 80

To see your current defaults:

defaults read com.apple.BluetoothAudioAgent

Edit 4 (2016-07-14): One more (hopefully last) edit. Make sure that you restart the bluetoothaudiod (or coreaudiod) service after making changes to these settings.

sudo killall bluetoothaudiod

Or, if you are on El Capitan:

sudo killall coreaudiod

Credit for this goes to the multiple wise nerds below who suggested it. (Thank you!)

  • 5
    Tried on El capitan, the commands don't work...
    – Fred K
    Commented Jan 1, 2016 at 13:28
  • 7
    After running the commands I saw no change, so I restarted bluetoothaudiod: sudo killall bluetoothaudiod. Reconnect your audio device after that. Amazing difference in sound quality. I always thought my speaker sucked. (El Capitan)
    – h4xnoodle
    Commented Feb 16, 2016 at 3:46
  • 2
    Nothing works for me with El Capitan. The only option for me is to reboot and then it works fine (not even the sudo killall bluetoothaudiod). Then it works perfectly for a couple days-weeks (so, no problems with positioning or other devices interfering). Commented May 21, 2016 at 13:28
  • 3
    Thanks for this! I was getting huge delays when starting playback (i.e. spotify would hang for 30+ seconds before audio would start coming through my Bose QC35s) Small update to your instructions if you don't mind, in El Capitan you need to sudo killall coreaudiod rather than bluetoothaudiod
    – micmcg
    Commented Sep 2, 2016 at 1:22
  • 2
    @micmcg Thank you for that! I've updated the answer to reflect coreaudiod.
    – Pierce
    Commented Sep 6, 2016 at 11:57

You can also tune the BlueToothAudioAgent by installing the bluetooth explorer that comes with XCode, and then within that, selecting tools..audio options. This gives a few more options, which are no doubt all also able to be set via the command line. There are also tools..audio graphs that you can look at to see what's going on. I found that tuning the number of buffered packets gave me good results (at least, until my bluetooth audio stopped working entirely).

  • 1
    Could you explain the sequence of Steps to get from Xcode installed from the MAS to having Bluetooth Explorer able to run? I don't see it except as a private download for registered developers, but I could be looking in all the wrong places.
    – bmike
    Commented May 30, 2015 at 19:13
  • 1
    No, that's basically it. But registered developers actually appears to mean "anyone with an appleId" because I think I just logged in with my appleId and it was happy.
    – PaulL
    Commented May 30, 2015 at 19:36
  • 1
    Apple Dev accounts are free. It's publishing to the app store that costs 100 per year.
    – cde
    Commented Oct 7, 2015 at 17:01
  • 1
    I used the Audio MIDI Setup found in Utilities. Commented Dec 31, 2015 at 2:02
  • 1
    @bmike You can get them by opening Xcode and selecting “Xcode -> Open Developer Tools -> More Tools” and then downloading the “Hardware IO” libraries after logging in with your developer credentials.
    – Anna
    Commented Apr 26, 2016 at 13:31

For those, for whom dealing with com.apple.BluetoothAudioAgent didn't had effect, for me reset of PRAM fixed the problem:

  • Turn off, then Turn on your Mac and hold down the Command+Option+P+R keys (hold all 4 keys at the same time)
  • Hold down all four keys until you hear the startup sound (Pauuuuum) twice. The startup sound for the second time means you’ve reset the PRAM.

Source: http://www.guidingtech.com/30498/what-is-pram-smc-mac-reset/

  • This did not for my case
    – Sgnl
    Commented Sep 20, 2017 at 20:47
  • I tried the "defaults write ..." options did not help. but along with this PRAM reboot, it definitely improved the situation (fingers crossed).
    – kctang
    Commented Apr 5, 2018 at 10:44
  • Tried default write ... does not work, try this works for me now. AirPods Pro's voice output on MacBookPro is more stable than before.
    – weaming
    Commented Aug 25, 2020 at 7:28

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .