0

I have MacBook Pro Late 2008 version. Recently I updated my OS to Yosemite 10.10.1. Ever since I've installed it I've been experiencing problems. The screen would freeze and nothing except the trackpad works. Actually the mouse pointer turns into the circle with rainbow colors and you can just move it, but you can't click on anything. After a minute or so everything turns back to normal and everything works fine. This was happening once per week or so and I was OK with it.

But yesterday I tried to update Java to the newest version 8.25 and Flash Player to version 16. After I updated them both the freezing have been occuring every 3-5 minutes. Everything else is working OK, except during the freeze time when I can only move the mouse. I tried to uninstall both Java and Flash, but the problem continue. Also I tried to install the previous versions, for example Java 8.20 and Flash Player 13 but it doesn't stop the freezing. What could I do?

P.S. I took me 15-20 to write this question since the freezing occured 5 times.

EDIT: You can download the console log from http://www.filedropper.com/consolelog. I have noticed that I receive certain message in the console log every 3-5 minutes and somehow it coinciedes with the timing of the freezes.

13.1.15 20:34:01,001    systemstatsd[358]   assertion failed: 14B25: systemstatsd + 4255 [8BF02DBC-09E8-3994-8C2D-1C0A869EF157]: 0xa
13.1.15 20:34:01,452    com.apple.xpc.launchd[1]    (com.apple.systemstatsd[358]) Service exited with abnormal code: 1

I can't provide an screenshot from my Activity Monitor since it constantly changing. And I don't know any other way to extract data from it. I was able to monitor the Activity Monitor during the freezes and there are no proccesses in the CPU menu and the CPU load is 0. But when things come back to normal the CPU Load jumps up to the max and it takes a while for it to return back to normal.

  • we need your Console log to see what is going on, and Info from your Activity Monitor, CPU load. – Ruskes Jan 13 '15 at 19:23
  • @Buscar웃 You can check the edit I've made. It took me a while to write it because of the freeze. – Stefan4024 Jan 13 '15 at 19:54
1

Your systemstatsd

The systemstats process is used to retrieve information about system statistics and power usage, and though it usually runs unnoticed in the background, the systemstatsd and systemstats processes have been known to randomly go haywire.

One method is to just kill that process for now.

In Terminal copy this and paste following

sudo killall systemstats

Enter your usual log in password.

You can do the same as above using your activity monitor, find the systemstatsd and kill it from there. (Force Quit)

After stopping it with one of above, do a SMC reset and normally it should not appear again.

|improve this answer|||||
  • I've killed it using the Terminal method. I killed both systemstats and systemstatsd processes. It says "No matching processes were found", but yet somehow I still get the 2 messages I pointed out in my Console Log. :( – Stefan4024 Jan 13 '15 at 21:47
  • Also I started getting messages in the console log like kernel: disk0s2 I/O error right before the 2 messages I pointed out. – Stefan4024 Jan 13 '15 at 22:08
  • OK, disk I/O is not good news. Try disk repair using Disk Utility in your Utility folder. – Ruskes Jan 13 '15 at 23:25
  • Thanks for the response, but I decided to format the disc and re-install the OS. After I have done it, I'm experiencing no problems. – Stefan4024 Jan 14 '15 at 21:33

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .