3

I've just upgraded my Macbook Pro (15 inch, mid 2009) to OS X Yosemite and it is running slowly and my Finder is not responding at all and none of my documents are on my Desktop.

I have tried taking off the transparency and nothing worked. I am not even able to access ⌘ CMD+r to reboot my system. I just went into Terminal and used the:

sudo rm -rf /.Spotlight-V100

trick but it doesn't seem like anything has happened. I do however have a response from:

julie:~my_computers_name  sample_command  client check in failed ... invalid destination port

How can I fix this?

  • Cmd/r doesn't restart the machine. 3 ways - hold power button for 1.5s or Ctrl/power for regular sleep/restart dialog - or Cmd/Ctrl/power to force shutdown. Your terminal command just erased part of the spotlight index, so it will have to do it again, making the machine slow until it's finished. – Tetsujin Jan 13 '15 at 8:09
2

When you say "none of my documents are on my desktop" do you mean that the desktop is completely blank? No Icons of any kind? So all you can see is your dock and the menu bar?

If that is the case Finder may not have loaded or might have just crashed and got stuck at login.

try this: Hold Command + Option and tap the esc key. That should bring up a dialog box with the option to kill any running tasks. Finder may be in there with"(Not responding)" after it. If so click on it and click on the Relaunch button.

If that box is empty then you have a more serious problem or if relaunching does nothing. Sometimes when you upgrade the O/S you have incompatible software installed. That could be the case here. Power off the Mac (hold the power button till it turns off) and then turn it on while holding the Shift key. This is called booting in Safe Mode.

Once you get the grey Apple logo release the Shift key and let the Mac boot. Safe mode turns off most, if not all, 3rd party additions to your system. It also does extensive disk checking so startup in Safe Mode can take substantially longer, depending on what is going on with the Mac. I've seen it take all night.

If you can boot up and log in under safe mode then there is something installed that is incompatible with Yosemite that will need to be uninstalled.

If safe mode does not work there could be a corrupt installation of Yosemite a disk error or something else that might take an experienced Mac technician to properly diagnose.

  • In my case, just the icon dock. Force quit menu is totally blank - no Finder. And no menu bars. ... time to power cycle, there goes all my work I guess. – frumbert Jul 7 '15 at 9:57
1

I had a similar issue in OS X 10.9.5

After trying aaaall proposals given in different forums and websites, the one that seems to work is the one suggested here:

Booting into “safe mode,” opening the Finder, poking around, and restarting.

Steps are:

  1. Restart your Mac.
  2. As soon as the grey boot screen appears (or slightly before), press and hold shift on your keyboard.
  3. Once you see a progress indicator, let go of shift.
  4. Once your Mac boots, you’ll have to login to your account (auto-login is disabled).
  5. Open the Finder. Navigate through a few folders.
  6. Restart normally

You must log in to answer this question.

protected by Community Aug 30 '16 at 16:32

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .