16

When I get a new text, it appears both in the Messages app on my iPhone and in the Messages app on my Mac. The iPhone text show the person's name, and the Mac text only shows the person's number. I have Contacts checked under iCloud sync. Both OSes are latest.

  • 1
    Is the contact on your Mac? Can you search for [their name] and find it? If it isn't, you probably don't actually have the contacts synced through iCloud. The config for that can, in some cases be a little ambiguous. You can easily determine, though if they are in iCloud on your iPhone by opening the Contacts.app and turning off the "On My iPhone" (or similar) group. If that person, or many people disappear, that could be your answer. – bassplayer7 Jan 13 '15 at 1:56
  • Okay, thanks. Looks like most of my iPhone contacts were coming from the "Gmail" contact group, so I added a Google account in the Mac Contacts app, but the couple contacts I try searching for still aren't there, even after sync. – Loren Jan 13 '15 at 2:15
  • Adding my Google account to Contacts app on MacBook was my solution. – cellepo Dec 17 '18 at 0:29
  • iCloud sol'n, took me < 30 seconds: youtube.com/watch?v=nO90IJ9wmeA – BoltzmannBrain Mar 3 at 22:38
13

I have been having this same problem and as I go through this thread I found that I could answer yes to everything, but the problem persisted.

I ended up opening the Contacts page on my Mac and while the contacts I needed were in "All Contacts" they were not in the "On My Mac" so I highlighted them all under "All Contacts" and did a drag and drop into "On My Mac" it fixed almost all my problems.

The ones that it didn't fix I found out that the formatting on the phone number themselves were not correct. For example the one on Mac messenger was 1(234)567-8900 while the contact card did not have a 1... so, (234)567-8900. Changing those two things fixed everything.

  • 1
    this is such a mess apple – SuperUberDuper Sep 3 '16 at 13:05
  • If you don't see "All on My Mac", click View -> Show Groups, – Josh Kodroff Aug 27 '18 at 0:59
6

I found that going onto system preferences/icloud then selecting the Contacts to uncheck it then selecting it again helps to sync it!

  • I actually had to do this about 6-7 times, disabling then enabling my Gmail account until something finally clicked and suddenly all my contacts appeared. – Cory Klein Sep 8 '17 at 20:52
1

I assume your contact sync all fine. Match telephone number work a little bit different with iOS and OS X, please check the person's telephone number format. and very important, check "system preferences"->Language & Region" settings, make sure OS X could match the telephone number format.

  • this worked for me!! – Rajeshwar Jul 16 at 6:26
1

I had the same problem. I opened Contacts app on my macbook pro went to preferences > accounts > icloud

it added my icloud account and pulled all my contacts from my phone/icloud.

0

I was having the same problem, I just barely figured out how to make it work. If you open up the contacts app and look along the left-hand side it shows which contact lists you have connected to your computer and the messenger app. Just make sure all accounts linked to your contacts in your iPhone are also linked in the Macbook. My problem was I have three accounts linked to the contacts on my phone, but only two linked on the computer.

0

So the problem for me was that I previously had an android device and all my contacts were associated with my Gmail account. When setting up my iPhone SE, I imported all my contacts from Gmail.

  1. On iPhone (iOS 11.4.1) : Contacts.app -> Groups -> All Gmail (checked). If I uncheck it, I no longer have any contacts. This diagnoses the problem.

  2. On Macbook Pro : Go to Gmail -> click on 9 box menu (top right) -> Contacts -> drop down bar on top left -> More -> Export -> Export as vCard (called contacts.vcf).

  3. Import contacts into iCloud. This can be done from either www.icloud.com or macbook pro. On Macbook Pro (OSX : 10.13.6) : Finder -> Applications -> Contacts.app -> File -> Import -> select contacts.vcf. On icloud.com (log in from web browser) : Contacts -> Gear Wheel (lower left) -> import vCard -> select contacts.vcf

Additional information:

  1. About vCards
0

This is not an iCloud syncing issue, it's an issue related to the default account used for Contacts on your phone / iPad.

After searching for a long time, I finally figured out the missing info - I wasn't able to find this anywhere else, so am posting here. A brief explanation, solution is below the separating line.

If you've got iCloud sharing set up & are confident that it's not a login/logout issue etc then it is probably that your phone / iPad is adding new contacts to an account that is not your iCloud account.

If you're like me, you might not have realized that the iOs Contacts even distinguished between different groups. Even if you did notice the "Groups" button, nothing inside iOs Contacts.app tells you that there is a default account. Even if you view a particular contact card, it won't tell you the group it's in.


  1. On your iOs device, go to preferences > Contacts (when I search "contacts" in preferences, it gave me three options, take the one that has the same icon as the Contacts.app not* iCloud, **not privacy).
  2. Click "Default Account" and set it to "iCloud" (if it was already set to iCloud, then you are having syncing issues).

Now, when you add a new contact, it will be added to your iCloud contacts by default, and so will sync properly.

N.B. This won't fix previously added contacts. It will just eliminate the problem, moving forward. You'll have to be sure that the previous default account is added to Max OS Contacts.app and can try dragging and dropping to iCloud, but mine was set to an Exchange account which is supposed to be synced with my Macbook, and those contacts aren't showing up; new contacts added to iCloud do.

Hope this helps someone else - can't believe it's not explained better on Apple's support pages.

You must log in to answer this question.

protected by bmike Jan 18 '16 at 18:17

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .