3

I'm having the most frustrating problem with iCloud on one of my Macs. Firstly, the Mac (a late 2012 iMac) was working flawlessly with all iCloud services up until a few days ago. Now, I am able to login to iCloud in my OS X user account fine, but no messages are ever displayed, no continuity features work, Messages will not send (some users show as not being registered with iMessages, some the message simply fails to send, and if I text myself I see the iMessage on that Mac only), FaceTime tries to dial but never completes, etc. This happens on all user accounts with all iCloud accounts on this Mac, not just mine. The same iCloud account works fine on a different computer (MacBook Air) and an iPhone running newest version of iOS 8.

I'm not at all sure if it's related, but I created a Mavericks VM in VMWare Fusion and signed in to iMessages on that VM on the iMac just before the time it started having issues, which worked and continues to work fine (the VM running on the "broken" iMac).

Here are some things that I've tried:

  • reset the PRAM (many times!)
  • reinstalled the OS (did not clear the drive first - didn't want to lose my stuff, that's next step. and also it seems insane)
  • updated to 10.10.2 beta (this somehow got Messages to start sending SMS (although it is not enabled to do so on my iPhone!) messages but it is otherwise still broken)
  • changed iCloud password to force all devices signed into account to sign out
  • ensured that serial number shows in About This Mac
  • changed my DNS records to google's, 8.8.8.8, 8.8.4.4
  • tried other iCloud accounts
  • turned the computer off for a few hours
  • deleted ~/Library/Preferences/ directory and ~/Library/Messages/ directory to force full data reset of Messages app and iCloud preferences, then rebooted, but seems silly since all other users are having issues
  • left iCloud logged out for a few hours and logged back in

Any help or suggestions is greatly appreciated it. I'm torn between calling Apple support (since the computer is out of AppleCare) and reformatting the computer to try to fix it.

edit: Mac has been connected to the network via WiFi and ethernet since problems began, no difference on either networks. Other Macs and iOS devices working fine on the network, and the network works great for all non-iCloud related stuff. I can go online, send files over network, etc. No issues.

  • Clarified, added paragraph at end about network, and I'm pretty sure I know what's in ~/Library/Preferences/ and ~/Library/Messages/ and feel comfortable deleting them, thanks – CamHenlin Jan 12 '15 at 23:01
  • Why did you change your DNS servers to use the Google ones? Are these Google DNS servers particularly near from you? – dan Jan 12 '15 at 23:11
  • I read about Yosemite having problems with resolving DNS due to its new mDNSresolver so I swapped my ISP DNS with the Google ones to see if it helped. I listed it here so it wouldn't be suggested again :) – CamHenlin Jan 12 '15 at 23:13
  • I never saw such a problem except on cases were the location is configured to Automatic and the Mac spent its time switching between Ethernet and Wi-Fi. Changing the DNS server to a further one is a solution if your DNS server is a real failure. This cannot fix a supposed failing DNS client. – dan Jan 12 '15 at 23:22
  • 2
    Did you sign out of iCloud on both the real & VM OSes? Even de-authorise the VM too. A guess is that 'the cloud' thinks they are one & the same machine as the MAC addresses will match & has chosen the 'wrong' one to get friendly with. – Tetsujin Jan 13 '15 at 6:43
1

I was following along because I had the same iMessage problem and just today I finally got it to work. I logged out of messages and iCloud and all my Macs, both virtual and physical machines. I think it was a VM I last logged out of that got things going going again.

  • Did your account work in the VM for a while before having issues? I've been playing with this some more and it seems like if I create a new VM (with new VMWare-generated serial number), I am able to stay logged in on that VM for a few days prior to having login issues. – CamHenlin Jan 16 '15 at 16:51

You must log in to answer this question.

protected by Community Jan 19 '15 at 0:10

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .