Since upgrading to Yosemite, I am having weird issues with sleep mode on my MacBook (mid-2011). Whenever my MacBook goes to sleep, it begins beeping (similar to POST codes on PCs) every 1-2 seconds, and I am forced to do a hard reset. This does not seem to happen when I am not connected to a peripheral monitor (Dell 21" monitor, and DVI adapter), however. Is this a known issue with Yosemite?

EDIT: Sometimes, this happens even without being connected to the monitor. The MacBook just goes into sleep mode, and begins beeping. Only a hard reset remediates the issue. Can someone provide me with a documented cause of this issue, and a fix?

EDIT 2: I've been fiddling with this for weeks, and I still do not know what the root cause is. I've used alternate profiles, eliminated the sleep image (per suggestion below), removed items from startup, and I still get this persistent behavior. Sometimes, after I do the hard reset, the Mac will not start back up after several attempts, but usually does after some time. I have done a hardware test, had it bench tested at a local Apple repair store, and tested the SSD for issues. None seem to be present. None of this happened until I upgraded to Yosemite. I'm out of ideas on this one. Hopefully, someone else has had this experience and can point me in the right direction.

  • Does the beep sound like this? youtube.com/watch?v=30y6NTIwIaQ Jan 28, 2015 at 5:17
  • The beep is the same tone, but it is a single beep, and it continues until I power off the device.
    – user55390
    Jan 28, 2015 at 17:53
  • Would you happen to be connecting your MacBook to an Active Directory domain by any chance?
    – Dave
    Mar 31, 2015 at 18:26
  • Yes, I am in an AD environment.
    – user55390
    Mar 31, 2015 at 19:08

3 Answers 3


I had a similar issue with mine (mid-2011 MBP running Yosemite), where not only would it go to sleep and not wake up, but it would reboot and freeze midway through the startup process. It would take several hard restarts to get back to a login screen. After awhile, I came across a thread on the JAMF Forums with users having similar issues. I found that this fixed it for me (keep in mind that I am also):

 1. Open System Preferences and select Users & Groups
 2. Select Login Options
 3. Select Edit on the network account server button/section
 4. Select Open Directory Utility
 5. Select Active Directory
 6. Select small gray arrow pointing to the right on the left side to collapse
 7. Uncheck "Force local home directory on startup disk" 
 8. Select the OK button.

I also deleted the sleep image and hibernate mode as per the above poster's suggestion. Since doing both these steps, this issue has gone away.

  • Thanks. I made this change to my MBP, and so far, so good. I will let you know if this does the trick.
    – user55390
    Apr 1, 2015 at 15:34

EDIT:Make sure that you save everything you want before doing this

Try changing the hibernate mode to RAM only, run this Terminal command:

sudo pmset -a hibernatemode 0

And, try deleting the sleepimage. From /private/var/vm/sleepimage.


sudo rm /private/var/vm/sleepimage

Then type your password.

  • Thanks. I will try to change the hibernate mode, and deleting the sleep image. I've taken to simply turning off my MacBook now instead of allowing it to stay idle, as I cannot pinpoint an exact set of circumstances that causes this action. I know that it is killing my productivity to have to recover my system from the constant freezes and gray screens that result though. Hopefully, Apple comes up with something concrete to solve this issue sooner before later.
    – user55390
    Feb 23, 2015 at 14:43

Check out this Apple Support article about startup tones. I know you're not getting the beeps on startup but a hardware beep indicates a hardware issue. Startup tones are not necessarily only heard at startup.

Apple Support article: http://support.apple.com/en-us/HT202768


  • Sounds like you're getting the 3 successive tones with a 5 second delay. This indicates the RAM does not pass a data integrity check and your RAM might have having problems writing to the hard drive on sleep. (Macs write their current RAM data to a sleep image on sleep, that's what sleep means.)

What to do:

  • Try powering down your Macbook, removing the back case and remove one of the RAM sticks, leave the other one installed.
  • Reboot and see if you're still having the problem.
  • If you are, power down again and replace the RAM stick you removed and remove the other one. Reboot and try again.

The chances of both RAM sticks having an issue is unlikely. It's probably that one of them is bad and needs replacing. (Might be a good opportunity to replace both with new up-to-date RAM, but up to you.)

  • The fact that it doesn't occur when you've got your monitor plugged in is most likely because your Macbook isn't going to sleep with an external monitor connected. No sleep means no RAM write to hard drive issue.
    – Bootle
    Jan 30, 2015 at 17:17
  • Bootle, my original statement was "This does not seem to happen when I am not connected to a peripheral monitor" but I have since observed that it happens either way - connected or disconnected.
    – user55390
    Feb 18, 2015 at 21:23
  • Additionally, it is not 3 successive tones, but a single tone, with several seconds between another single tone. When I do a hard reset, it comes back up at the Apple startup screen. Sometimes, it goes directly to the login page very quickly. Other times, like right now, it simply sits at the Apple logo and progress bar, with the fan cranking.
    – user55390
    Feb 18, 2015 at 21:26
  • So I powered it down, waited a few seconds, powered it back up, and it went to the login screen within seconds. I am running an SSD, so I don't expect startup to take a very long time. It typically does not.
    – user55390
    Feb 18, 2015 at 21:28
  • I see, sorry for that, I must have misread. If it's just one single tone every 5 seconds at startup, this indicates that no RAM is installed at all. But the machine wouldn't boot with no RAM. At this point, I'd suggest running an Apple Hardware Test (AHT). you can find more info on how to run it and what to do here: support.apple.com/en-gb/HT201257
    – Bootle
    Feb 18, 2015 at 22:58

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .